Homey Community Forum

Beacon - An app for presence detection using BLE beacons

app
tools
#102

I’ve had this app working with great results with a Gigaset G-tag on Homey v1.5. But since I’ve updated to v2 it stopped working. I’ve deleted the tags and app, reinstalled, but it’s not able to detect the tag anymore. The app used to be able to see some bt devices in my house as well, for example my soundbar, but those won’t show up either. Could this be a Bluetooth issue with v2? Or is something else broken?

0 Likes

#103

See my comments: 51 and 63

0 Likes

#104

So I have the same problem again. The beacons work for a day or something and then remain on detected Yes.

Then I need to p2p to have it working again.

In the non working state it also doesn’t find the devices when going to the add wizard.

0 Likes

#105

Thats very strange, what homey firmware and app version have you? Can you send a log to the developer, then i’ll have a look.

Goto: /manager/settings/#homey:manager:apps
Click one time inside the white frame with: Apps installed on Homey.
Hover the app: homey-mi-flora with the alt key and wait until the Send to developer button appear and click on it.

0 Likes

#106

Thank you for your reply. Does this mean it’s impossible to add a new tag to Homey currently in v2? Or is there some way to get it to work?

0 Likes

#107

All the functionality is the same in the v2 compatibel version: v1.2.0. All issues of not triggering flowcards are resolved in the newest RC as wel.
Except for the discovery of the beacon itself. That does not give 'live results as mentioned in de skd-app issue ticket to athom on github. Athom is looking for a fix for this issue ‘soon’ untill than the app wil not be compatibel.

0 Likes

#108

What is the typical range (meters) in which a tile is detected?

0 Likes

#109

Please read the openings post:

Here is a list of used devices

* Tile Pro (8m)
* Tile Mate (8m)
* Nordic nRF51822 (5m)

0 Likes

#110

Thanks Koktail. I saw the opening post with the ‘(8M)’ marking. I thought it was a type marking or some kind.

Their website says 90 meters:

So 8 meters depending on the model?
Any reason for the range decrease from 90 to 8 meters?

0 Likes

#111

Wall for example.

0 Likes

#112

I guess I shouldn’t have reinstalled the app while trying to fix it. Ah well, I’ll wait for a fix from Athom then. Thnx again for the info.

0 Likes

#113

2.0.0 is out. Somebody tested de beacon?

0 Likes

#114

The known issue in not resolved.

0 Likes

#115

Shit😬

0 Likes

#116

I’ve updated alpha

v1.2.1 - 11.01.2018

  • update icon because of wrong viewport
1 Like

#117

Once this is solved, I will finally migrate to f/w v2.0

1 Like

#118

An extra update before the weekend would be nice😜

0 Likes

#119

App Version: 1.0.17
Homey Version: 1.5.13
Log: The unique log ID is: ed76a9cc-6b8c-46d2-911f-d24aa7a7f7ed

I spent a little bit of debugging to understand the issue.

The problem is that the two Beacons (Tile Pro) don’t do anything after a while. The detected remains the same state, whether you leave or arrive. During this error-state, when I add a new beacon. The beacons can not be found in the add-a-new-device wizard. The log that I sent you is during this error state.

When I reboot the Homey (p2p not even required, just reboot launched from the system menu). The beacons are immediately seen from the add-a-new-device wizard. And, when I leave/arrive the detected status is properly working. I test this by putting the beacons in a metal box.

And it works for a while, but often not longer then a day. I’m currently thinking to create a flow that reboots every night to see if it that is a working workaround.

I have two flows per Beacon, one arrival flow and one out-of-range flow. Example:

That’s it. That’s all I know. I really hope you can figure it out.

0 Likes

#120

I’ve looked into your issue and checked the logs. I cannot find anything strange.
At some time the device of E***** is detected outside. What is the verificationAmountOutside setting you using? The beacon should be undetected a couple of times to filter out false positives.

In your log i see:

[✓] beacon:E*****
[✓] beacon:C*****
All devices are synced complete in: 5.52 seconds
All devices are synced complete in: 7.532 seconds
[x] beacon:E*****
beacon:E***** changed detect outside: 1
[✓] beacon:C*****
All devices are synced complete in: 8.469 seconds
✓] beacon:E*****
[✓] beacon:C*****

Looks like the beacon is out of range but after some seconds it’s back again. Or is this the false positive we want to filter out?

Have you tried to remove the battery or go away for real?

1 Like

#121

The beacons are attached to the keys; so they are actually leaving the house. I tried removing the battery but it didn’t help.

The settings are all set to default.

If you don’t have suggestion, illl contact at hom support

0 Likes