Homey Community Forum

Blind flow help needed

Hi all.
I have created a flow to close my bedroom blind.
When temp, lux, and afternoons sync.
What iam finding is that at random times of the afternoon the flow repeats the audio message.

Anyone able to help with why?
Or any betterway to handle the flow?

Thanks.

The flow will be triggered every time the temperature changes. You must include a “and Dim > 10%” in the flow so the flow wil only be execute when the blinds aren’t closed yet.

Ok … thanks.
Like this?

Yup

Ok…so the blind flow failed today :hushed:

What happens when you press the test button?
Which condition/card stops the flow? Red cross?

No crosses :worried:, but today i had to put it down manually.

What percentage is fully open and what percentage is fully closed?
I’m just wondering if the logic needs to be less than 10% but then 10% closed doesn’t seems very far down.

Also is the Dim Level tag definitely for the blind?

I had also already thought about whether the dim level is the other way around. But it is the same with my blinds:
100% = open
0 % = closed

If it should be different in his case, he should have had a red cross at the dim level in the test.

1 Like

So it failed again today.
I checked the multi-6 and lux os 5800. Temp is 33 and it’s after 1pm. So all parameters are triggered.

0% is fully closed. 10% is almost closed bar for a little light to get through.

Thanks for the ongoing assistance :blush::+1:

If the logic values lux and temperature in the section “And…” come from the right devices, everything should be fine. I see no error.

Maybe you rebuild the flow completely new… :man_shrugging:t3:

Did it get to 33 before 1pm or when the lux was lower?
The trigger only fires when the temperature changes so if it gets to 33 and stays there before the other conditions are true then the flow won’t run.

P.S. I wish it was 33 here :grinning:

Ok… so I recreated the whole flow and it failed again today :frowning:

Ok but this has been working before, other than the echoing of the voice. Only adding in the blind greater has broken it.
Is there a better way of writing this flow??

Instead of the trigger temperature I would prefer a variable.
However, the variable would have to be set in a separate flow.
The easiest but maybe not the best solution is the following:
When… Temp. > 26
Then… set Variable „Temp_Bedroom“ to Yes
Else set Variable „Temp_Bedroom“ to No

Replace the temperature sensor at If… with “When a variable has changed” in the main flow.
At And… you have to replace the logic card temperature with the logic card “Temp_Bedroom” is “Yes”.
The variable “Blind is greater than” I would delete.

The advantage of a variable is that it does not change constantly and thus triggers the flow.

If you use the temperature as trigger, the flow will be triggered every time the temperature changes above 26 °C.

Wondering, when or on wich condition the blinds has to go up again?

Perhaps you could use, disable/enable card.
So when they gonna down disable the flow, but at some point you have to enable the flow again

Perhaps dim level is in decimals, like in bulbs? Try “WHEN dim level is greater that 0.1” instead od 10.

Ok. So i made the flow with variable.
If i run the flow manually it works but it wont run itself.
:pensive::pensive:



Variable set


Your second flow only sets the logic value to “yes”, and it stays “yes” as there is no flow/logic that puts it back to “no”, so there is nothing that changes?, where your first flow responds to.

Ok. I see that.
I just also noticed in the variable i have not set a temperature. And i don’t know how to do that as nothing i look at seems to allow me to.