Homey Community Forum

Broadlink App

HI All - in the end I just bypassed Homey all together and control the Broadlink directly from Google Home. Except for the sunrise/sunset capability the Homey is now an expensive ornament.

I should say the broadlink has worked perfectly direct from google home.

Mark

1 Like

Athom and and the App Concept.
A curse and a blessing at the same time!

Shit happens :man_shrugging:

hi please advice with instruction how to learn RF command from TC2 wall switch (no remote controllers are available, only wall switch)? thanks.

Since some time the Broadlink app “forgets” the commands I learned the RM-mini. Every few weeks they are gone, and I have to retrain. Little complicated as I am not allowed to use the same names. They still seem to be somewhere in the memory. Re-installing the app didn’t work. Rest of Homey works okay. Do we know of some app conflicting with Broadlink?

Is @Remko still on the forums?
Can add a mini but cannot learn codes. Tried 2.0.4 and 2.0.5 on Homey versions 2.5.2 and 3.1.0.
U have some advice maybe?

So I’m actually lucky! I also have 2.0.5. Can still install the mini and learn codes. They even work for some days. Wow! :grin:

Had the same if I add the mini with the e control app it works the mini learns codes.
But when I add the mini with new app broadlink universal remote is does not.
The mini is recognized but it does not react when pushing the learn button.
All of this is with 3.1 and tested a few days ago.
Hope the homey app gets updated so that it works with the new app from broadlink as the old isn’t supported anymore.

1 Like

Ah thnx, that works actually!

I have an issue with linking my e-control added devices (and the new broadlink app) to the Homey app. I can register them easily in the individual apps, but then in the app on the Homey, it says RC commands 1,2,3,4,5 etc. When pressing one of the buttons it takes me to a menu where I can give a certain command a name. But how do I link this name with the command registered in the e-control or Broadlink-app? Also, how do I teach the e-control app or Broadlink app an RF command?
Do I need to add the devices manually into the Homey RM Mini3 app directly?

Thanks
Kristoffer

My best guess is ur answer is 2 posts above yours.
I also tried to add IR devices to the mini but that didn’t work because i had the Broadlink app installed on my phone. I then trew that app away and downloaded the Broadlink e-control app. Added the mini to Homey and added the IR controls in the Homey app. When adding the first IR device the number 1 command gets a name. In the advanced settings u can give that a proper name to remember.

Hi @Remko,

First of all, thanks for making this app!! I’ve been slowly adding all my electric blinds. I’ve just added the 3 in my Dining Room and the list was about 12 long. When I go into Flows, I can only see the commands for the 10 and 11 (the latest that I added). I restarted the App. I’ve now gone into Advanced Settings and I see I only have 3 in my list now. It seems to have deleted all the other RF Command :sob:

I’ve been renaming the list - does that screw things up? What naming convention should I use? I’ve been using names like “Left Dining Room Blind Up”. Is this what is screwing it up?

Hi @aeonax,

Hmmm. I’m stuck with this. I have my IFTTT account linked to Broadlink and when I try and create a trigger , I get to the screen Which Device - and I get Options Unavailable. I’m using the IHC app on my iPhone for RM Pro+.

Thanks, Jason

Which device are you trying to control? IFTTT limits the types of Broadlink devices mostly to on-off switches and TVs, but there is a workaround. For example, I have a “switch” called AC heating and I’ve paired it with the IR command for my air conditioner heating mode. When I switch it on via IFTTT, the IR command gets transmitted and the AC turns on.

When adding such switches, don’t use the library codes. Use the “can’t find my brand, learn remote” command. A weird thing is that this option is not available by tapping + in the upper right corner. You have to select the Broadlink device and then tap “add appliance” in the bottom. Then you get the option to add unsupported devices. 🤷

This is all provided that the IHC app is correctly paired with the IFTTT.

Good luck, I sure was pulling my hair until everything was set up, but now it works without any problems. :grin:

Hi!

Firstly, I’d like to complement You for a great app! I’ve been using it successfully with a RM mini 3 for a year or two!

I was on Homey version 1.x but experienced the famous Homey upgrade freeze the night between October 30 and 31 2019. That forced me to upgrade to version 3.x and since then it seems like the recorded IR signals are lost every time Home upgrades. (…at least the two upgrades that had been rolled out since my factory reset, that is 3.1.0 and now 3.1.1)

If I go to RM mini device’s Advanced settings, I can see the previously recorded RC commands but nothing is sent If I use some of my old flows. If a try to make a new flow there are no commands to choose in the “Send Remote Command”-card.

After the upgrade to Homey 3.1.0 I discovered that if I removed the last command and recorded it again, that command alone showed up in the “Send Remote Command”-card. Therefor I recorded all the commands once more in the exact same order and gave them the exact same name, and everything worked again.

Is there a way to avoid having to record the RC-commands after a Homey-upgrade?

// Henrik

Is there a way to slow down the RF transmitting? Flashes too fast for my blinds, about 10th of a second. So quick can hardly see it lol. It’s a learnt code if that makes any difference

Hello! I’m using this app for unlocking my doorlock wich works with RF 433Mhz. I have learned my broadlink k the commandos from the original remote, and it is working, sort of. But not as good as with the original remote.

Thing is, I need to press the button on the original remote for at least 1 second. Than it always works.

But with this app, I can not define how long the button need to be pressed.

Sending out the commando a couple of times in one flow will work, but than there is a big delay.

Does one of you have a suggestion?

I bought a broadlink rm4 mini and I’m not able to link the broadlink account with google home can anyone help

And you sure you dont want to ask this on a gh forum instead on the homey forum ?

1 Like

please integrate the new devices like broadlink rm4 mini :pray: