Homey Community Forum

Bug with philips motion sensor?

is this a bug?
when i move, the motion sensor blinks red, so it does a movement recognise. but in the homey app, last action 5 hours ago.
unfortunately there are more than one motion sensors affected. restarted homey, same issue. deleted device readded works.
I’m using homey for 3 days now, about 35 zigbee devices.

any hint?

Guess that you are using the motion sensor connected directly to Homey and not through the bridge? Then it’s a known issue since several months. https://github.com/sebbebebbe/com.philips.hue.zigbee/issues/61

this is really annoying. a smart home without a motion sensor is like living without. I can switch via the main power, via a zigbee switch for each bulb or via the mobile phone.

Removed 7 motion sensors trying to readd them for 3 hours. added one sensor, but the recognition time is false, seems like this big feature is broken.

Write to support@athom.com and complain. Maybe they’ll finally fix this issue.

The sensors are working through the bridge though.

ok i will think about…
which sensors are you using?

By working ‘through the bridge’ they mean - due to a limitation in the way that the bridge works, motion events will be delayed by several seconds. (less in the newer versions).

So it is a trade off.

hey @Jamie

5 hours are a little bit more than few seconds :slight_smile:
thanks to @Osorkon, he gave me this idea to connect Philips devices and devices like Dresden electronic to connect them to the Philips hub. than I have updated 9 hours all of Philips bulbs and motion sensors. readded all motion sensors, bulbs via the other homey app for Philips hue. now i have the devices in my Philips hub and also in homey, this is really great! it is working perfect.
anyone who had some issues should try this!!!

solved my problems :slight_smile:

@adem_p Sorry I was replying to

If you try and create flows in homey using the Hub - using motion sensors or the remote - there will be a delay of a couple of seconds. ie. If motion detected turn on fibaro light.

Yes, that was just a small help to adem. Haven’t got the bridge myself, but am aware of the delay issue, yes. Am still waiting for the fix from Athom.

1 Like

didn’t have anymore either ^^ but prime now is fast :smiley:
it’s really cool in that way
the delay is the same… I guess. if I remember the delays of homee, there is no delay

The latest version of the Hue app has reduced the delay - as far as I am aware it cant actually be ‘fixed’ its got to do with how the bridge communicates.

Rather then it telling you that there is motion, you have to keep asking it over and over ’ has there been any motion’.

Philips hue has stated a year ago or so, that they want to implement a push API (now indeed a pull API), but still haven’t done so unfortunately.

Delay now for motion sensors and switches is maximum 2 seconds, bulbs current interval is still 5 seconds.

1 Like

but after 2 sec the bulbs get on/off there is no need to ask the state of a bulb if you just want to trigger via motion sensor

push would be very nice, didn’t know that it is planned

I have really no luck :frowning: with my devices… added yesterday, les s.d than a day all devices are unreachable. restarted homey, devices available. omg

next day exactly same issue

this is homey bug I guess?

Make a Flows which restart the Philips Hue App every 2 hours.

Unfortunately it’s a knowing issue without a solution so far. I have also the same problem.

1 Like

k thx, and how :)?

via homeyscript
await Homey.apps.restartApp({id: ‘magic.home.wifi’});
await Homey.apps.restartApp({id: ‘com.swttt.homekit’});
await Homey.apps.restartApp({id: ‘nl.scanno.mqtt’});
return true;

Per Flow:

I don’t have that, is it an app?