Homey Community Forum

Cannot add xiaomi stuff for homey pro

i have 2 homey , 1 is homey and 1 is homey pro. both at 2 different house .
for homey i able to add mi gateway and able to connect to stuff like wireless switches etc by using xiaomi mi home. i just have to click add device and choose xiaomi mi home then mi wireless switch it will auto scan and load the device for me to choose.

but for homey pro i do the same thing but when i click to xiaomi mi home and install it keep saying no “new devices have been found”

i already try all ways and a week but still still the same . it work well for homey but not homey pro.

pls pls pls help thanks

I have the same issue, but have an early 2016 Homey. Never got it to work with the Xiaomi gateway. So, I don’t think it’s a Homey Pro issue! Unfortunately I don’t have a clue what the problem is…

Good luck! And if you do solve this issue, please post the procedure!

1 Like

i have 1 homey and 1 homey pro
homey2016 work well with xiaomi and can connect to xiaomi gateway then it can connect to xiaomi wireless switches ,door and window etc etc

but my homey pro can connect to the xiaomi gateway but not the wireless switches ,door and window etc etc

it keep telling me no device found…
is there any setting i missed or ? coz i set up these 2 device together but at the different house.

Not sure if it’s any use, but there is an app for Xiaomi stuff without using the Xiaomi gateway… Aquara & Xiaomi zigbee
I just connected humidity sensor with it, an no issues at all…

Noob here - can you please tell me how did you connect the xiaomi gateway?

This is the screenshot from homey pro , and homey also same , I check both homey and homey pro all setting is the same.

But the different is I can use homey Xiaomi app itself to connect with xiaomi stuff by click example door and window sensor or wireless switch (screenshot),

then it will show the ip address and tick to choose in my homey ,then I just have to click then it will appear in my homey device And also mijia app . Mean I can see the door and window sensor even the time open or close in mijia app and homey app .

But for homey pro it keep telling me no device is found . (Screenshot)

and the only way is to connect is using aquara & xiaomi zigbee app to pair them. But this way I only can see the xiaomi stuff only in my homey apps but no more in my mijia app.

Mean homey can connect both homey and mijia app and set flow either from homey or mijia app. Using (homey xiaomi app)

But homey pro only can connect either one mijia or homey pro. Using ( aquara xiaomi zigbee)

@Calfred_Lor

I have exactly the same problem, but in my case with the ‘standard’ Homey; after adding the gateway I have a similar screen as you posted from your Homey Pro. After that, I can’t add devices. I see the same screen as you see “No new devices have been found”.

So same problem, but with the standard Homey, not Homey Pro. So, it seems impossible that it is related to the type of Homey you use…

Anyone found any solution?

If I remember right the problem was discussed in another thread and it was appointed to different firmware versions found on the Xiaomi gateway.

I bought a second gateway and that one works fine: devices are seen in Homey.

Seems that on some gateways the needed port 9898 is closed.

See: https://www.home-assistant.io/integrations/xiaomi_aqara