Homey Community Forum

Can't get MQTT Broker app to run

Make sure that the module configuration in the Tasmota firmware matches the driver that you’re using to add the device to Homey.

i checked the module. it is basic (1) and the driver selected is tasmota basic. Uploading: 20190530_172603 (1).jpg…

Picture21
still not finding the device. console after restart:
00:00:05 MQT: Connected
00:00:05 MQT: sonoffflood/LWT = Online (retained)
00:00:05 MQT: sonoffflood/cmnd/POWER =
00:00:06 MQT: sonoffflood/INFO1 = {“Module”:“Sonoff Basic”,“Version”:“6.5.0(release-sonoff)”,“FallbackTopic”:“cmnd/DVES_000000000000000000000000000_fb/”,“GroupTopic”:“sonoffs”}
00:00:06 MQT: sonoffflood/INFO2 = {“WebServerMode”:“Admin”,“Hostname”:“flood”,“IPAddress”:“192.168.1.172”}
00:00:06 MQT: sonoffflood/INFO3 = {“RestartReason”:“Software/System restart”}
00:00:06 MQT: sonoffflood/RESULT = {“POWER”:“ON”}
00:00:06 MQT: sonoffflood/POWER = ON
14:22:36 MQT: sonoffflood/STATE = {“Time”:“2019-05-30T14:22:36”,“Uptime”:“0T00:00:14”,“Vcc”:4.094,“SleepMode”:“Dynamic”,“Sleep”:50,“LoadAvg”:22,“POWER”:“ON”,“Wifi”:{“AP”:1,“SSId”:“Workshop”,“BSSId”:“B0:39:56:7E:3F:A5”,“Channel”:11,“RSSI”:92,“LinkCount”:1,“Downtime”:“0T00:00:04”}}

It looks like you’re using a non-standard MQTT topic setting. The “full topic” setting should be the default value: %prefix%/%topic%/

The “topic” setting can be chosen to your liking. For example, I have this configuration for my Sonoff RF Bridge:

image

its working like a charm

appreciated. it was the non-standard MQTT topic setting issue. much appreciated

regards