Can't set Multi Mode Virtual Device with action card


#1

A Multi mode VD can be set via the Homey App, but it seems it can not be set by a Logic action card setting the MM VD variable to the desired value.
Is this as designed or a bug?
MMVD01


#2

You should type the name of the tag. Dragging the variable in there will use the value of the tag.

In Homey v2.0 we will enhance logic tag support.
(from here: https://github.com/athombv/homey/issues/2247#issuecomment-380402773 )


#3

Thanks. Tried it, but it creates a seperate variable with the same name as the Multi Mode Virtual Device, but the MM VD status itself is not changed.
I guess your suggestion does not work for MM VD status?
Therefore the topic is not solved yet.


#4

Its not a bug i believe. But whats the reasson you wanna set it in the way you asked?


#5

Ahhh… Sorry,
didn’t seen you where not using a normal Logic Tag (Variable) but a Multi Mode from the Virtual Devices App.

You need a Action from the App
image


#6

Yes, I guess it works as designed. Then it’s a feature request.
The reason is that I use this for the home-mode which can be Home, Away, Sleep and Awake.
The change of this mode will trigger flows, like turn some lights on at random time interval when I’m Away.
Changing the home-mode can only be done by the Homey App. But I also want to change it with a Remote with some buttons that change the home-mode and trigger the flows as well.

At this moment I use a work around. When the home-mode is changed by the Homey App, an extra variable is set with it’s value. This extra variable is also set by the Remote. The flows are triggered by a change in this extra variable. This works fine, the only disadvantage is that the status of the home-mode is not set and therefore the value in the Homey app is not in sync. Example: The home-mode is set in the app to Away. I press the Remote’s Home button. This new status is not reflected in the app. Not a big thing… but wouldn’t it be nice…


#7

I also use the multimodus (home-away-sleep-holiday) and it took me a while to get it working as it should.
I can manually set the status by using the virtuele multmodus, just by clicking home away ect.
But it also set automate when leaving home to away ect. then the status in the app also change. So let me explane what i did.

I you want to set the state of the mode, in any flow just using the card …

Knipselmulti%20weg

Then the mode also change in the app to away.

The flows your making straight for the Multi state you have to use a extra card in the and colum see pic below…

NOTE, IN THE LAST PICTURE flow dont use the card “set multi mode” in the then colum. this way it works like it should.


#8

That is the solution I was looking for.
I did nor realise that I had to use the VD device card itself instead of the VD card of the App.
Thanks!


#9

Unfortunately it seems that this does not work in all cases.
It DOES work when the multi mode is changed via the app.

It DOES NOT work when assigning it in a flow. In my case I use a Remote to set the modus, like IF button X pressed THEN set multi mode to ‘Weg’ (Away).
The flow which catches the change (see last picture of Roy’s post) is triggered, but it fails on the test if it’s ‘Weg’. I suspect that the Multi-Modus-Veranderd trigger was handled before the value of the multi modus was changed.
Workaround: So, I added a flow that is triggered by the Multi-Mode Veranderd (Changed) event and then start the flow to check the value of the multi-mode with a delay of 1 sec. This works as a charm!

I wonder if this is unique for my configuration -or made a misstake-, or if this can be reproduced by someone else?


#10

@vdneut iam not really understand how you set up your flows with the multimodus. because like what i explaned this works perfect for me.

Help me out with this…. you using the remote as a trigger, the action in “then colum” is set multimod away. right?? this is working??

Making flows for the device Multimode, you did what i showed you in the picture…

But what you do in the “then” colum? you should put the type of action in here, for example start flow a or put lamp on. Not playing with the card set multimode here.

Maybe put a screenshot of the flows we where talking about.


#11

Yes. Please find the flow…


I have to break the reply as I’m e New user which is limited to one picture upload per reply :frowning:


#12

And this flow should say ‘Hoi’ if the multi modes changes to ‘Thuis’…

But it does not! It gives unexpected and random results, some times it freeses Homey (giving constant orange ring color) and need to reboot.


#13

It does work and behaves as expected after I added a delay between setting the multi mode and checking the value in the IF.

Strange huh? :slight_smile:


#14

As i showed earlier in the topic dont use the card "Multi-modus is exact"in the And colum. use the logic card there with the tag


#15

Sure thing! This works! No delay nescessary.

Conclusion: use the multi-mode device card in IF and THEN, but not in AND. Use Logical test of Tag in the AND.

(Surely I accept this way of working, but it’s a bit confusing that the mm device card can be used in the AND, but does not work. Also, not documented at the app’s github).

Thanks for your help Roy!

Thread can be closed - Solved


#16