Homey Community Forum

Casting YouTube video to Chromecast Audio no longer works

Casting a YouTube video to a Chromecast Audio no longer works. I’ve seen the reports that it is supposed to work again in the beta/version 5.0.18, but it does not. Previously this worked (even though the Chromecast Audio is audio only; it would just play the audio from the YouTube video, which is what I want).

It’s not very clear what to put in the parameter field now. There’s no label, and the “help” text in the field when it’s empty says “Zoek een YouTube video URL of een vi” - pretty useless. Nevertheless I copy and pasted a YouTube video URL in there, assuming that’s what’s being asked.

When I try to run the flow, no audio is played, and a red error icon appears on the YouTube card, saying “cannot read property ‘connect’ of null”. With version 5.0.17 it would appear to work (no error), but there would still be no audio.

How can I cast a YouTube video to my Chromecast Audio again?

Besides there are some topics alr about the Chromecast app: You wanna cast a video to an audio device?

I didn’t see a topic that addressed my specific issue, all I found were topics saying that it works again in version 5.0.18. If I missed a topic that addresses this issue then my apologies and could you point me to it?

And yes, I wanna cast video to an audio device; did you read my third sentence?

Can’t this be related to Google dropping support for the Chromecast Audio?
(they already stopped selling them)

EDIT: The homey app probably just uses the api that is released by Google (or something like that)

Yes i did. But the app changed and an update is not always an upgrade. Did u make a request at Athom alr for this?

And this is one of the topics.

I saw that topic, but none of those problems are what I am experiencing. I get that an update is not always an upgrade, but it should not be a downgrade, especially not when it gets automatically installed without warning.

What is “Athom alr”? (So probably not…)

A request already.

Put auto update off.

Could be, who knows. Although even if they stop selling it I would not expect them to just stop supporting it altogether, making thousands of devices that people paid good money for useless. The Google Home app still supports it fully, and even the Homey app does automatically find the device, and offer the “play YouTube video” function for it.

A request already

Do you mean an official support request? No not yet, I first wanted to check whether this was a known problem before bothering them.

Put auto update off.

Are you suggesting that I just turn auto update off for all my apps, on the off chance that updates might be missing functionality, even though I will get no improvements or security fixes any more? Or are you saying that I should somehow have known that this particular app would be updated with missing functionality and have turned off auto updates beforehand just for this app?

Yes sir! And also for Homey FW updates!

That’s an unhandled bug in the code (I guess Athom forgot to add a proper unit test for it… :expressionless:). You should report it to Athom.

Yes sir! And also for Homey FW updates!

Really, are there so many problems with them? This is the first time I’ve encountered a problem like this. I guess I’ll have to consider it then, thanks for the suggestion.

You should report it to Athom.

Thanks, I’ll do that, now that it looks to be an actual bug and not a known problem.

Alright, I reported the issue to Athom using the link @robertklep gave me.

Very nice!

I use one with spotify on a daily base so i hope not but i never tried to cast a video to / with it so i don’t know if Google supported and dropped support for it or not.

Yes same complaint here. The home mini or smart speaker does not play a casted YouTube video with only audio