Homey Community Forum

Change Wifi in homey 2.0


Can anyone find a way to change the wifi network in the new 2.0 APP?
And does anyone know if recovery mode still works? doesnt seem to work for me.

So i got no way of changing the wifi password atm.


1. Turn on Homey

Make sure Homey is upright and on. Make sure that Homey is on for at least half a minute before you continue.

2. Turn Homey upside-down

Keep Homey upside down, and wait for the 10-second countdown to finish. Homey is now in recovery, and will ask you to go to setup.athom.com on a computer, just like when you install Homey for the first time.

3. Open setup.athom.com on a computer

Go to setup.athom.com on a computer with WiFi and follow the instructions on the screen. Choose between clearing all data (restore to factory settings), or keeping the data and continuing to use Homey. With the wizard on the screen you can now (re) connect Homey to the WiFi network you want.


This should really be built into the new app though, as Athom are pulling away from desktop applications and programming.


Homey v2.1 will then include Backup & Restore functionality, which backups your Homey’s settings to the cloud. We’re still uncertain if the Homey Smartphone App will include Wi-Fi Setup at launch, but if we didn’t make it, Homey v2.1 certainly will, because it’s required for this feature.

– Behind the magic july-2018

You can read more about it and whats next here


Turning homey upside down. Starts the countdown, and after the countdown it even says. That homey is going in recovery mode. But no Wifi network of homey appears. Recovery mode gives a blue spectrum from the ledring, but in 2.0 it gives me the normal colour spectrum.


:thinking:, I think it is time to contact Athom.


Did you already find a solution for the recovery mode?


No I haven’t fixed it, just havent changed the wifi password.
When i turn Homey upside down, it starts the countdown. When it reaches 1, and wait. I turn homey again and steve says. System recovery cancelled.


have you send an email to athom about this? https://support.athom.com/hc/nl/requests/new


But u need to turn Homey on her feet again when she ask u to do so.


You’ve turned the Homey back on its feed just to soon. Just keep it upside down, while changing the WiFi-settings. And only after the new settings are entered via the temporary network & web-page, bring the Homey back on its feed. Just did it myself and this worked well.


I noticed it took some time (like half a minute) before she (with a male voice BTW) started saying “Hi, I’m Homey…”.


You are right, takes like 30secs. First the red light starts to burn brighter. Previous version was alot quicker.