Homey Community Forum

Changing command class for fibaro keyfob

Hi!
I see here that i need to set my keyfob command class to something else to be able to use the sequence lock feature.
https://manuals.fibaro.com/keyfob/#post-2639
I also read here:
http://forum.micasaverde.com/index.php?topic=52450.0
that you can send a command to the remote to change this
Then i tried to use this tool:
https://developer.athom.com/tools/zwave
to send a equivalent message but i wasn´t able to get it to work. I would appreciate if anyone could point me in the right direction so that i can get this thing setup the way i want. Thanks in advance for any help i can get.

The device (advanced) settings page does this all for you when you enable the lock mode.
No need to do anything manually, it will be very difficult to do this manually, as your keyfob is included secure, making this the hardest thing to do manually you have ever tried, unless you know how to handle the security thing(s) going on, at the right timings.

Yeah! I have done that but still no locking action here. Does this seem correct?

As in the description of the sequences, 2 of the same buttons can’t be after each other, so 4;4 is an Invalid sequence.
But also, do you wake up the keyfob just before you press save? (a value does need to change from the last save, otherwise the value(s) wil not be send)
The keyfob will not wakeup on its own by default.

Yes i have woken it up. Still no luck have also tried to reset it. Can’t figure out what I am doing wrong.