Homey Community Forum

Chromecast and reconnect to speaker

My chromecast app wont reconnect my speaker when it goes off for a longer period. The only solution is to either restart the app or reboot Homey. The speaker is connected to a power switch that turns off via KNX during the night, thus it is not possible for the Homey app to connect. Is there any solution other than restarting Homey or the app? Apart from the obvious - move the speaker to an outlet that does not turn off at night. But it’s not that easy as this power outlet (KNX) is the only place where we want the speaker located…

It’s not a solution but maybe a workaround.
You can restart the App automatically using a flow.

Thanx, but I found another way. Pause/disable an app. :+1:

Did you give your chromecast devices a static IP?

2 Likes

Now I can remember. 🤦
I had the same behavior with Sonos. A fix IP solved the issue.

There are no option for static/fixed IP on my chromecast devices…

You need to do that on your router, or the device handing out the IP leases.
In case of a FritzBox for example you can tick the option “always assign same IP to this device”

1 Like

Sorry, you mean the hardware itself ?! Thought you meant devices in Homey. :grimacing:

Yep

Done! Testet it a couple of times now, and voila! Thanx!! :blush::+1:

1 Like