Homey Community Forum

Chromecast issues after last update.. (beta)

I had 4 Google Home devices and a Philips TV with a Chromecast Ultra enabled through this app.The update killed all of my flows, mainly the ones that I used to switched on my TV when I started a flow to prepare the bedroom for the evening or the wake up flow that I got triggered through an alarm, starting my TV with a ‘good morning’ webpage that I run on my local NAS with news and weather forecast, and my Google Home mini playing a radio station as my wake up call. All of that is now destroyed… So, I removed the app, reinstalled it twice (stable and beta) to see that for both occurrences nothing of my previous experience returned, it is now even not detecting all of my devices any longer!! :frowning: :frowning: :frowning:

Should I abandon this app completely?

I think you just have to repair your flows. After a reinstall you always have to repair them. I also had to do that. App is working correct on my two home minis an two Chromecasts

Trust me, I have “repaired” them multiple times in the past days to no prevail. Nothing works, my TV also won’t start anymore with my Chromecast in the ARC port, which it did before the update. And as I stated, it wouldn’t even detect all devices now… just one Google Home speaker of all 6 previously detected devices.

This app has been completely unusable for me for about 2 months now. I have to restart the app daily. And it won’t cast to speaker groups anymore either. Really a shame as this was one of the primary reasons why I bought my homey :confused:

What kind of devices are these?

Which version of the app are u running at this moment?

This is being worked on by Athom.

4 Google Home speakers
1 Google Assistant capable Philips TV
1 Chromecast Ultra

And I have experienced the same problem with casting no longer working. Only recently installed the beta version but no devices visible yet…

Ok. Have Chromecast app 0.5.17 running here. Philips TV with Google casting, a mini, a hub and an ultra all being discovered and working here. Did u report this issues alr? And did u delete the devices and then tried to add them again? Just trying to help here.

Thanks for the help, yes all deleted… app deleted, restarted and recreated. Not sure yet if the detection is App related. I see them all on my LAN though… Not reported as issue, still troubleshooting a bit :wink:

Ok, good.
Ur sure they are still all on the same network aye?

Oh yes… flat Class C public IP network (LAN) on my end.

Running 5.0.18 beta now. The “stable” version wasn’t doing anything better.
Sounds good that they’re working on getting groups to work again.
Thanks for your dedication @Rocodamelshe :+1:

I know, however;

  1. (Currently,) This interface seems to be unstable with tunein radio started with homey
  2. the Tunein app ahs differt functionalities (off course) and is build for radio stations. So if i want more control (like easily switchen between stations), Homey is not always the desired go-to interface (which i, off course, do not expect of homey).

My experience now with the latest beta;

Starting a tune in radio station is working fine for Google home devices, but streaming it to a chromecast device (in my case a built in chromecast in an xiaomi android TV box) I see something happen on my TV, the stream seems to be starting, but nothing happened.

Also, when I say to my Google home devices after homey starts a tune in station but after I say; okay Google, stop it doesn’t respond and it keeps playing. Really strange…

1 Like

This is EXACTLY my issue sinds an update one month ago. It really sucks and I’m looking for a way to downgrade, since I had zero issues and everything (including radio casting to multiroom speakers).

Yep terrible downgrade this update… dont fix it when it ain’t broke!
Have to restart Homey trough a flow every night just to keep my chromecast device available

Me too

Discovered I’m also having the same issues with flows that cast to my Google nest hub, as discribed Here. Chipped in by contacting athom. Restarting the chromecast app once in a while makes it managable. At least this way it “isn’t broken” all the time.

I am not sure if this is a fix. But I noticed that the chromecast-switch for the hub was off. Switched it on and it was working again. The switch can be found under devices.

what kind of switch? could you clearafy this?

Does anyone know why there isn’t a way to trigger a flow with “Chromecast paused”. I can see chromecast in “playing” or “paused” on my devices view when my wife start/pauses her tv show (casted via an app) and I would like to trigger something when we pause a movie/tv-show (increase brightness of lights/open our shades/etc). So it’s clever enough to detect whether it’s playing something or not, but it’s not possible to trigger a flow on this?