Homey Community Forum

Community Backup & Restore for Homey v2 [Alpha Version]

Hmmmm… Loading is something different than downloading.
I am away for some quality time but did you check there where no cloud issues at that moment as I have seen some recently. https://status.athom.com/
Beside that are you able to test it with Chrome? That is what I used to build and test. Do not immediately have an option to test ie, edge or Firefox now.
Also look if you have browser extension active and Fe look if flow.homey.app works that one uses in general the same technology.

Tested here and it even works from my Android tablet…

Succes . Hoop you keep us informed

Hello Dijker,

Thanks for the quick response but i think quality time has priority over anything :wink:

Did the logon procedure again and installed chrome. Now it works.
Look very good, nice work!!!

Thank you.

HI Dijker,

Just wanted to thank you for this great effort creating something that Homey should have had from the beginning. Too bad about the lack of Z-Wave restore otherwise it would be perfect for me as I have a lot of Z-Wave devices. I’m forced to wait for Athom, but hopefully just as the Google integration they all of the sudden quietly release this. Hope it happens before my Homey breaks or I’ll be done with Homey forever.

You could test what happens when you migrate Z-Wave devices to groups app devices and link a manual re-added Z-Wave to that virtual group device.
Beside the manual pairing I think it should work but could have some unwanted side effects. I did not have time to test thoroughly.

Geurt,

Sorry for my late reply.
Just tried it again and now it works.
First time i only got to the first screen.
Not the second one where you can choose what you want to do.
But, it works now.
BTW, I use Chrome on my phone.

Thanks.

1 Like

Did some testing last week. Backup went smooth, but had troubles importing my devices and flows. I don’t have any spare time anymore this weekend, so maybe I will try again later.

I’m still doubting if I’ll wait for the Athom backup functionality since I have many z-wave devices (some in places that are very hard to reach when I need to exclude/include them) with around 665 flows that need checking or work. A 1:1 backup would save me a lot of time.

@Dijker did a hell of a job though! :+1:t3:

Mapping of Z-Wave and Zigbee devices
HCB&RWA can restore a Z-Wave or zigbee device to a < groups> app device.
it will do this if you enable the option on the first tab and the z- device is not on Homey anymore but you want to restore it from a backup. The created groups device Wil have the same capability as the original z- devices.
After restoring the flows that uses this devices they should work. You can add the real z- device to the group device to let them operate and switch accordingly.
Pls test and report if it works for your devices.

Restore of 433 kind of devices
Restoring a KAKU or some other devices works and automatically pairs with the same 433 code so should work most of the time. Pls also let me know if restoring a Nexa, Telldus or other 433 device works and results in working devices. I expect it to work as it works for other 433 devices.

Tested or reported 433 and other devices that can be restored:

  • KlikAanKlikUit (trust/Coco)
  • HomeEasy
  • ScreenLine Remote

Devices not able to restore a working version yet:

  • Solar panels SolarEdge
  • Thermosmart
  • NetAtmo

These are on my list to get a Restore working, either by fixing the restore process or by adding an option to replace the devices after that in broken flows.n

2 Likes

Hier zat ik op de wachten. Goed werk.
Backup gemaakt, dit werkt goed. Maar de 2e keer probeer ik weer in het backup scherm te komen, krijg ik deze melding:
{“code”:400,“error”:“invalid_request”,“error_description”:“redirect_uri does not match”}
wat doe ik verkeerd?

You can find your answer here. @Maurits_Van_Dinther

Ik did this the first login. That worked fine. But the second login does not work.

Your session expires when you close your browser, so you have to repeat the procedure you did on the first login every time.

1 Like

got it, thanks. i bookmarked the wrong url.

Glad I found this thread. I feel a lot better now that I have a backup of my Homey.

Great job and thank you very much!

wow that went smooth. Looks like i have a backup know. Wil sleep better now :grinning::grinning:
if my homey would break down it would have taken me weeks to get it right again.
Thanks for the good work

greetz Frans

I did query this with Homey support after all my Hue lights dropped (i basically had to start all my flows again). The answer wasn’t what i expected:

  1. They denied they ever promised backup in 2.1. After I sent them the screenshot and link they said “they didn’t look back that far”.
  2. They didn’t acknowledge the need for backup but stated “they’ll make sure they don’t promise features in the future”

I came away from this response feeling they were super arrogant…and hugely disappointed by the reply. There was zero empathy for the issues created by not having a backup.

Homey staff; if you’re reading this. Either do your own backup feature; or give this author the APIs and access he needs to get backup working fully.

Keep up the good work @Dijker and thanks

6 Likes

Onestly thats the athom company whe all know.

Great product homey, with a huge potential. But sadly ,and they proven it already to many times its the wrong company behind the great device.

But they stil can learn, and hopefully there comes a time…

2 Likes

Yes that and I see a that users are also getting more crap every day . Backup will come . If you don’t like it :wave::wave::wave::wave::wave::wave:

And if you look closer to the homey api you will see the first parts there for homey backup .
Go look it’s open for everyone to see on the dev pages .

They can’t do all at once . Users are nagging for features all over the place

1 Like

Hi folk.
I read this thread and it seems very interesting.
I have an ordinary Homey (early 2019), and I am running out of memory, and I have more apps and devices to add so realized that I bought the wrong version. So I just bought a Homey Pro, and am about to “migrate” my content to that).
I have sent a supportquestion to Athom yesterday, and see if they have any timeplans to share (I do not have so much hope, but the more people that ask, maybe it will come). So this may be a way to do it.

Just some thouths before I start.
I have like 50+ devices and 60+ flows.
I can see that HCB&RWA does not support restoring ZigBee and Z-wave devices.
More than half of my devices are 433 via KlikAanKlikUit, and it looks like this will works fine.
Only like 10 of my ZigBee-devices are directly connected to Homey (due to the problem with the ZigBee-stack…). Then I have lightbulbs via one IKEA-gateway and one Hue-bridge. Does the gateway and bridge come over, with the devices connected via them, or do I need to do something manually here?
About the directconnected, you write “it will recreate a App device when that option is selected”. Maybe I am stupid, but what does that mean?
Some kind of pointer?
What I see infront of me is that I restore as much as I can, and then I re-add the ZigBee and Z-wave devices manually afterwords, and correct the flows.
Is that a way to go?

Am I thinking right? Any other tips?
Thanks in advance.
/Stefan

Nothing to do with back up, just beging curious. Your talking about 50+ Devices and 60+ flows !!! Thats for sure not much… and homey should handle that with no problems. The number of apps could be something for considering a homey pro…with that said, about how many apps your talking?