Homey Community Forum

Connecting Homey to Visonic (previously working with Vera)

I’m in the progress of migrating from Vera to Homey. So far it’s gone pretty well, but I’ve run into an issue connecting my Visonic Powermax Pro Alarm.

On my Vera it was successfully connected using the available plugin, however this was using a serial to usb adapter. My alarm has the genuine Visonic RS232 interface.

Obviously that wasn’t going to work with Homey, so I’ve connected it to my network using a USR-TCP232-302 RS232 interface, as that was the closest I could find to one discussed in the documentation for the plugin.

I have set the interface to 9600 baud, 8 bit data size, no parity, 1 stop bits, local port number 23, and its set to be the TCP Server.

I then run through the configuration wizard setting it to the same IP and port number as above.

I receive the error message to ‘Enrol the panel in PowerLink mode’, however I cannot find how to do this with my panel, and it’s not in the user manual. I also note that the error message states that that PowerMax Pro with partition supports enroll automatically. My panel has partition support.

Any guidance how to overcome this? Have I got the settings correct on the serial to ethernet adapter? Is this the issue?

Should I do a full reboot of the alarm? (Disconnect the battery and mains supply)?

Thanks for any help

To help anyone who else runs into this issue, after spending hours trying to get this to work by using tools to see what the Visonic alarm was sending over the comms ports. I started to wonder if either my Visonic internal serial adapter was mis-behaving, as even connecting my pc directly to it I was getting garbage.

I ended up removing the internal serial adapter, and the TCP232-302 RS232 interface, and replacing it with the TCP232-T2, and connecting that directly to the PC/IP socket on the alarm.

It worked straight away :slight_smile: