Homey Community Forum

Control multiple devices (lights) with Fibaro Walli Dimmer

Hi,
I want to create a flow to power on/off all the lights in my living room. When pressing the Walli dimmer I also to want to control two other Telldus power outlets with lights attached when I press the Walli button.
It seems the Walli doesn’t have the full set of variables implemented. For example I would like a “when button 1 is pressed” option.
For my Telldus devices there are variables like “When state changes” which would also be applicable to the Walli.
Have tinkered with this a while, can’t make it work.
Can anyone lead me in the right direction?

Running Homey Pro with the latest FW.

//Johan

Hi Johan,
something like this? (Sorry, only in German)

Therefore your Telldus must be configured as „Lamp“ (Type of device: „What’s plugged in?“).
In the category “And…” you theoretically only need one device (lamp) which is queried.

Thanks,
I see in your picture that you have something called “scenes” in your Walli, it seems I missed something here? Only had the Homey for a week…

Ah, okay. For this you have to activate “Scene” for switch 1 and/or switch 2 in the advanced device settings (parameter 40 and 41).
Simply enter the required number in the field and save.

So, I’m lost😂

Tried to add 40,1,1;41,1,1 in Advanced Settings in my dimmer. The “Parameter size” can’t be set to “1B” as described in the manual, if adding just “1” it works though.
However I don’t see a choice of 40/41 when I create a flow and add my dimmer in the “When” stage of the flow.
Where do I take wrong turn?
Googled this a lot and can’t find any examples of how to do this, even though it is documented that it can be done. :smiley:
See my screenshot of my Advanced Settings, sorry for the Swedish…

Ok, so it seems that the Walli Dimmer is not properly supported by Homey yet. You had replied to that thread as well.

Hopefully it will be available soon.

Cheers,
Johan

Hi Johan,

I’m getting old, sorry!
But unfortunately I can’t try it myself, because I don’t have a Walli dimmer in use. So I can only believe what @Osorkon and @JesseR said in the linked post.
Nevertheless I find it strange, because the Walli Switch was integrated into much later and Scene Activation is supported.

You can do two things now:

  • check in the App-Store every now if there is a new beta version of the Fibaro App and if Scene Activation has been added (you can get beta versions if you go to the App-Store and add a “test” at the end of the URL)
  • Contact Athom by mail (support@athom.com) and report the error. I hope @JesseR has already done that and I will do it too because I will probably buy a Walli Dimmer as well.

Sorry again for the confusion!

Cheers,
Dirk

One question, @HomeyRaman,
What options do you have if you add the Walli dimmer as a card in the If… section?
Could you please post a screenshot similar to this one:

Here is a screenshot, missing the expected choices in the “When” section of a Flow:

Also I’m missing the button section you have for your Walli Switch in my “Advanced Settings” for Walli Dimmer:

Regards,
Johan

I have submitted a “Request device support for Homey” and asked for this to be added to the app. To me it appears to an oversight, they just missed it. Let’s hope it can be added soon.

Cheers,
Johan

I have asked this before at Athom to support this, because right now it’s not supported and I got only walli dimmers inside my house.

You can make a official request at Athom to support it by this link. Maybe if more people ask it happens quicker.

Which option do you mean exactly? Which parameter is that according to the manual?

You’re right. I got a response from Athom today and I’m also supposed to submit a feature request, so let’s do it.