Homey Community Forum

Correct procedure to disconnect z-wave products

First day with homey, (2.0.4) I’m doing some test.
I added 2 fibaro devices to the homey and after I have reset to default the homey.
I spent a little our doing reset to the devices because I didn’t unpair them form the homey.
After reset to default of them ( very painful ) I wasn’t able to reconnect them with fibaro app and I add them with generic z-wave module in homey.
I would disconnect them from generic and reconnect with fibaro app ( more options ).
The question is:
what is the correct procedure to disconnect z-wave devices?
Form developper page pair/unpair?
From developper page / devices and trash them
From developper page / z-wave remove node
I’m getting confused with those all options
Thank you for your replies

They will all 3 end up in the same result, removed in homey as device, and the device itself reset back to factory defaults, so you can choose whatever you want.

The last one is the most important, that the device itself has been reset to factory defaults

infact I was looking for the correct procedure who assure that the device will be reset at factory setting and ready for pairing again.
Wich one do you suggest to you?

The easiest way is to just delete the device from the device’s overview, and activate the inclusion mode of the device.

But even if that fails to reset the device, you can always reset the device from the developer tools, and remove a zwave device from there, that will reset the device to factory defaults, even if it is not included into homey.

Trying to remove multiple zwave devices of Qubino but the remove button is grayed out. Is there any way to force the remove?

Homey has latest available update installed 3.0.0

Hit the test button and wait for the remove button to become active

Thanks for the tip.

Just sharing some experience:
Yesterday I had to remove and add about 14 Qubino devices because I used the beta version 2.0.10. I started doing this with a very positive mindset. Unfortunately it took me 8 hours to complete :(. The removal and pairing of zwave devices in general is not working consistently as it should be in mine opinion.

tried all possible ways to remove and pair devices and some worked instantly and some I had to do over and over again.

Removing devices through the developer page you should only do for broken devices.
If the device is still paired with the controller and it’s working, you should exclude the device!

Because homey doesn’t support NWI it is necessary to do the inclusion very very very close to homey.
After an Inklusion is failed you should exclude the device first before start the inclusion again

Someone made a nice post about including Zwave devices!