Homey Community Forum

Daikin AI

you can do this simple check using a webbrowser…

enter http://xxx.xxx.xxx.xxx/aircon/get_control_info url in your webbrowser, replace xxx.xxx.xxx.xxx with the IP-address of your Airco and you should see a response like shown below.

ret=OK,pow=0,mode=4,adv=,stemp=24.0,shum=0,dt1=24.0,dt2=M,dt3=21.5,dt4=24.0,dt5=24.0,dt7=24.0,dh1=0,dh2=0,dh3=0,dh4=0,dh5=0,dh7=0,dhh=50,b_mode=4,b_stemp=24.0,b_shum=0,alert=255,f_rate=A,f_dir=0,b_f_rate=A,b_f_dir=0,dfr1=A,dfr2=B,dfr3=A,dfr4=A,dfr5=A,dfr6=A,dfr7=A,dfrh=5,dfd1=0,dfd2=0,dfd3=0,dfd4=0,dfd5=0,dfd6=3,dfd7=0,dfdh=0

If it is not working try replacing http with https.

If you see this response in your browser Daikin AI most likely will work, however no guarantees nor support for this adapter/heatpump combination/model.

Thanks for the quick response. If I try connecting to the lan controller using http I get error 500: 192.168.86.40 is currently unable to handle this request. However the Daikin app works fine to this address. Looks like I’m out of luck!

That does not look good… Well if you already own a Homey you can simply install my app and try it of course… in that case do not forget to disable “demo mode” in the Daikin AI (my) app (when enabled my app will always keep the heat pump/airco powered OFF…).

I do have a Homey and I’ve tried the app, it just reports an error everytime (although the error vanishes so quickly I can’t read it!).
I’m unable to talk to the lan controller using get requests, I get server error (500) whatever I send.

The lan controller is a BRP069A62 which seems a bit newer than anything in the Daikin libraries. I know that when it’s first powered up you can connect to it over http but after 30 minutes it no longer allows web access - looks like they might have changed the protocol :frowning:

The app I use is called Daikin Online Control Heating, rather than Daikin Online Controller, so it may have a completely different operation.

I just want to be able to turn my heat pump on and off; nothing else really matters.

Your Homey (or the PC you are using for http://xxx.xxx.xxx.xxx/aircon/get_control_info request) and Heat pump are in the same subnet (192.168.86.xx) right? If not make sure they are.

Yes indeed they are. :frowning:

I am afraid you are out of luck… as long as you cannot get a response from the heat pump using your PC and a browser my Homey app will also not work. This also means that if you want to trouble shoot your situation all you need is your PC and a browser.

A note from the user manual…
Not all Daikin airconditioner models / model series / combinations of indoor and outdoor units are supported. Due to the fact that Daikin does not disclose their interface specification reverse engineering of the interface is extremely difficult.

As of today version 2.0.11 is available as stable version.

1 Like

I found the following link useful: https://community.openenergymonitor.org/t/hack-my-heat-pump-and-publish-data-onto-emoncms/2551/35

The brp069a62 uses web sockets for comms, and I managed to connect to it using the Chrome Websocket client - but haven’t got much further!

Hi Peter,

First of all I like you app. I’m using it for my 3 Daikin Stylish models.
Second my English is bad :blush:

I’m looking for a way to monitor the humidity in the 3 different rooms.
http://ip-adres/aircon/get_sensor_info
Shows
ret=OK,htemp=18.0,hhum=70,otemp=12.0,err=0,cmpfreq=0

So I like to see a tag with the humidity.

I want to create a flow that starts the dehumidifier for about 1 hour (or something like that).
The airco in the sleeping room is next to the bathroom. So I want to use the airco in stat of opening a window…

Is this possible to add to the Daikin homey-app, or is there an easier way to get the data to my Homey?

Kind Regards,

Nick van der Graaf

Hi Nick,

Noted your feature request, time permitting I will have a look if and how I can implement this.

Alternative: use an Mi Aquara temp and humidity sensor, create a flow based on the Aqara sensor instead of the airco’s internal humidity sensor.

Thanks for you’re quick reply.
I didn’t think about the xiaomi senors.:see_no_evil:

Hi, I think I have the same adapter as you BRP072A42. Did you get this fully working with this Homey App?

Thanks

Worked as a treat!!
If it’s the same as mine, should work for you too!

Hi There,
I have recently had installed the stylish and comfora. I can contril them both with the homey app, but they must be switched on via the Daikin App. I Cannot switch the units on with the homey app. Is there something I do wrong ?

Thank you

From the user manual…

Demo mode (upon pairing the demo mode is by default turned ON !!)

Demo mode can be disabled in the device its settings menu. Demo mode can be very usefull when you are designing new flows as demo mode prevents the airco to be switched on so you can safely experiment and test your new flows.

Works like a charm. Thanks a million for your tip.:+1:

1 Like

Thanks for this app, works almost like a charm.
I have a FTXM35N2V1B with BRP069B adapter added as Model HomeKit and works perfectly.
I also have a FBA35A2VEB9 with BRP069A81 adapter; also added as Model HomeKit. Switching on, modify modes (heat, airco) work, but switching off doesn’t work. Also changing temp reflects correctly to the airco but on HomeKit and Homey the selected temp goes back to 10°C after having selected. Could it be a big or should I have to do something else?
Thanks for everything

This model is not supported and might never be supported…

1/ make sure demo mode is turned off.

2/ make sure the correct (A?) wifi adapter model is selected.

3/ Send me some responses of your airco at different temp settings, modes, both when it is turned on and when turned off. See earlier posts on how to do this.

Hi Peter,

Have you got plans to upgrade support to homey v3.0?

I didn’t realise I had auto update turned on and since homey has been running on v3.0, the daikin app seems to have broken

Cheers
Rony