Homey Community Forum

Devloping a new App that communicates with Life360

Awesome app so far, never knew about this before.

I’m currently testing the app now too (1 person only), everything in the device gui is updated properly.
I do have some “issues” or maybe better said some questions/advice.

Capabilities:
Would be nice to have the distance, accuracy and speed as a number value instead of a string, so we can use the “logic: is more/less then” in conditions etc.
The “KM” etc can also be added with another tag in the custom capabilities (units)

Triggers:
Device leaves this place;
Device enter this place;
the autocomplete(?) selector stays empty here, or can it only display the “build in” places like “Home”.
As I translated them to “Thuis” etc.
Logging doesn’t state anything about it.

Also the “battery is being charged” has an option to enter a battery level, why?
And kinda missing the “battery charging has finished trigger”, gui will display “full” when done, so should be possible.

Logging is also only being appended? Which will probably make it really slow to load later on with the amount of text there (already getting slower here after 1 day).
I know I can delete it manually but if you forget, or don’t know it will fill up rapidly.
So maybe let it delete stuff from the end, or being able to disable the logging in its entirety?
Or will it be removed when the app gets into stable?

Thanks for all tips. I will take them with me in development. The places (like home) needs to be added in the Life360 app on your mobile but this is only activated it seems when you press the alarm bell after the place. Loging is currently large but will be reduce. Anyhow it will be striped after a certain limit.

Here the flow card is never populated (gives back “no results”) with available places, and yes I did define them in the life 360 app, and they also show up in homey’s GUI, just not in those 2 flow cards.

Just an IIRC for the capabilitie values from string to number, people will have to re-include their devices.

The bell has absolutely something to do with it. I tried everything else, rebooting, reinstalling and reincluding. Nothing worked until I checked that bell.

The only problem with that is that you have to have someone in your circle to check that bell.

Yes, very wierd. The homey Life360 App is working (for this part :)) but the problem is that the places are not comming trough the API of life360. So there must be some trick (other than the bell) to get them displayed them in the Api.

This morning when i am on my work i can se that te app showing “Work” so is looks like it’s working :slight_smile:

The only problem whas that the app stop working yesterday. When i leave my house this morning i get no message from Homey. At my work i saw that te latest update in the app whas yesterday evening at 18:48. After i restard the app everething working fine again.

I have now make a flow that restart the every night at 4:00

EDIT:
I just look in the app again and the text “work” is gon and show just an - again :upside_down_face:

This weekend I will work on some improvements and bug fixing. Probably you will need to re-include the device as Caseda was mentioned as I am changing some capabilities.

I have also dowloaded the app and i am testing it now. So far working fine exept that i see only 1 place like everyone. Will absolutely follow your work here :ok_hand::+1::+1::+1: Nice app

greetz Frans

Just now updated to the beta version. removed both devices from homey and reinstalled them. I see 3 places now :grinning::grinning:

today I ordered the paid version for a month (7 days free). I can ad now more places and they appear also in homey after a few minutes.

Just uploaded the bug fixing version to the store. Now waiting for approval. (This version requires to re-add your devices and modify your flows, sorry)

Can you please tell me which bugs are fixed as it looks like I did not have any. But it looks like so maybe I did not notice the bug?

Please check the Readme file.

Looks very nice, this solution but I cannot get it to work.

This is what I did so far:
-Installed life360 app on my android phone?
-Made an life360 account
-Installed homey connect to life360 app
-added my account details to the life360 app settings page in homey

tried to add a “life360 devices” to home, but after entering my credentials I get the message “unauthorized”…

Any suggestions? Did I miss anything? Or is there a tutorial?

Unauthorized means you got your username (email adress) and/or password wrong

Are you sure. I copy and paste both of them. Just checked on the website to be sure, and there it works…

I think my password was to complicated. Changed the password to something without special characters and now it works

I read the readme file and everything is working perfectly.
I am testing it now for changing the heimdall status.Looks like i finally found a proper working app for this. Tried lots of apps but they where often to late or did not respond at all

thanks for the good work

Greetz Frans

I don’t get updates from life360. Last update is 2 hours ago. Has this something todo with the “bell” mentioned before? I do not use this app with somebody else, so my circle is empty…

With me i did not work if you only have one person installed. Nothing hapens when you press the “bell”.
When you ad someone it coulers

That would be a disappointment… Anyone with a solution?

Hi Marcel, can the app also set the standard presence triggers homey is using like first person to arrive at place or last person to leave a place (preferably the Home place :wink: )?
Or should this already work, i have tried using these triggers but no action…