Homey Community Forum

Devloping a new App that communicates with Life360

Hello Marcel.
I was running a Homey Early 2019 (regular version) for a few weeks as test, started with 3.0.0, found the Connect Life360 app and worked perfect. Even after updating to 3.1.0.
Returned the Homey (regular) and bought a Homey Pro. After first setup it was immediately updated to 3.1.0. I found and installed all apps I had on the regular Homey , but can not find your Connect Life360 app anymore in the Homey apps. Could you (or anyone else) shed your bright light on this maybe please ?

Update : when searching “Connect Life360” through the Homey DEVICES (instead of going through Apps) I found it, but when installing it shows the message "An unknown error has occurred [build_not_found] (red banner coming down from top with the message in white)

I want to try installing the app (on a standard homey), but where can I download the app. I can’t find the app in de Appstore of Homey. It impossible with the new design of the app store. Could somebody give a link to the app?

And what if you try to instal it within the homey app.

Search for life

It shows up for me

Hello Roy, I tried from within the Homey app, but can not find it. What software version is your homey on ?

Homey V3…

Just go to devices, then add +. Then at the bottom of the page search for LIFE and walla

Thank you @RoyWissenburg I’ve found the app. I get the same error as @Nwakke. [build_not_found] on a regular Homey. Maybe someone has an idea what it is?

Hi, It this when you try to install the app?

Guess it stil has to do with the new appstore.

What version of Homey are u running?
Because this should have been solved when running the latest version.

Yes Marcel, the [build_not_found] error occurs when installing the app , after finding it through the devices-search (as the app can not be found in the app-search)

I am running the latest version, V3.1.0.
I’ve tried to install a few other apps, these will be installed correctly. But this app will not be installed.

Then it is not in the store (yet) and u have to ask the developer to update the app for the new store and bring it in for review.
@MarcelT ^^

Sooooooo hoping MarcelT would want and of so will find the time to do this, really missing the Connect Life360 app

I am busy pushing the app in the New store as it was not automatically converted to the new store :roll_eyes: . But it was rejected because the history was in the README file. The new submitting to the store (and the store itself) really lack of good documentation and functionality. I liked the old store a lot better. Now I need to find out how to fix this…

" Readme & Description

We have decided to replace the markdown description (README.md) with a plain text story accompanying your app. Markdown files are great for advanced users but quickly become cluttered and unreadable.

Now, a README.md file is optional and mostly useful for colleague developers visiting your source code. When submitting an app, the Homey App Store requires a README.txt file with a plain-text story accompanying your app.

Additionally, the description field in your app.json will be shown above this text, so make it beautiful!

We’ve migrated all previous apps and did our best to keep the formatting decent. It’s probably best to take a look at your apps and give them a small update.


You’ve asked, we delivered! When publishing an app, you’ll be asked What’s new? and this will show up on the app’s page. A .homeychangelog.json file is created automatically so anyone can view the entire history in your app’s repository, if it’s open source."

1 Like

Yeah, that I know. So how migrate the history to the new file?

I have republished the app, so now waiting for approval.


Had an update, so i thinks it’s approved😄

I just updated and it works again, i wonder if it is possible to make a card “if user goes faster then xxx” so i can make a flow when someone goes fast like on a train !

How did you update (and what). I still can not find the Connect Life360 app (through search in apps. It even does not show up anymore in the devices search

Edit: I 've found it :slightly_smiling_face::slightly_smiling_face::slightly_smiling_face: … by scrolling down, and there it was, under the “Recently updated” apps :blush::grin:… looks to be working at first glance… thank you so very much

1 Like