Homey Community

Dimming problem with Fibaro Dimmer 2 + Bypass


#1

I have a Fibaro Dimmer 2 with Bypass 2 that I can’t get to dim properly.

It’s installed in a euFix adapter according to the instructions, and it works in the sense that it turns on and off with both the app and the switch. It also dims up and down when holding the switch in.

My problem is that after calibrating with 4 different bulbs, including one recommended by the Danish distributor, none of them dims low enough.

I then tried to force the dimmer to use leading edge mode, and that improved the dimming dramatically - please see my tests HERE.

Why is this the case?
As I understand it it’s recommended to use trailing edge mode, but why? Is it harmful to the components to use leading edge?

BTW. both the Osram bulbs recommend using trailing edge dimmers according to the specifications, and I’m told the Philips does so as well.


#2

https://www.lamps-on-line.com/leading-trailing-edge-led-dimmers

The link above graphically shows the difference. It basically boils down to how how the sinus is broken up (at the start or at the end). Where regular dimmers just lower the amplitude of the sinus (lowers voltage) and by that make LED-bulbs go gaga (since they MUST have 230v due to the electronics in them, though some LED bulbs have built-in dimmers and can be connected using regular dimming (usually 4 or 5 steps) mechanisms, but that’s a story for another time :slight_smile: ).

For bulb-makers it’s more stable to build bulbs that are optimized for trailing edge dimmers. The electronics in the bulb need to be able to ‘predict’ when the maximum amplitude gets activated. With leading edge dimmers, it’s just suddenly there. (it starts of at it’s highest point), with trailing edge, it grows up towards that highest level and then gets cut down. This makes the the dimming less harmful for the electronics and should mean a longer life time…
Another advantage of Trailing Edge dimming, is that never has that annoying buzzing sound that some (cheaper) dimmers have. The power flow is also more stable in general.

Usually LED bulbs can work with both systems, but you should always follow the vendor’s advice on which to use as the electronics are optimized for that type of dimming.


#3

That was my understanding as well.

What I can’t figure out is why then can’t the Fibaro dim properly bulbs that are specifically made for trailing edge dimming?
They should perform better in trailing edge mode - not worse.


#4

If you only have one bulb behind the dimmer, I think the issue lies with the fact that your bulb uses too little power:

It shows a minimum of 5 VA if used with the Bypass. The IKEA bulb in your link uses 6W which is the highest of them all. So you’re basically pushing at the bottom here. Since you’re at the absolute bottom I think the power factor may also pitch in with the issues you’re experiencing here. I’m not an electrician so maybe I’m talking bullocks here :slight_smile:

If you have the option you could try a brighter (higher powered) bulb, or maybe connect two bulbs for testing purposes (if your setup allows you to do so of course)


#5

Side note:
Personally I think I would lose the idea of a dimmer and go for Philips Hue spots (or another brand with equivalent features), though they may be a bit larger than the regular bulbs (not sure on that). That allows you to both dim and change the colour temperature.


#6

I like the Hue spots as well, but besides being significantly more expensive, I’d also like to retain the functionality of my existing switches, and as I understand it Hue requires their own switches. It helps with the all important WAF (wife acceptance factor) :slight_smile:

I understand why you’d think there was only one bulb connected, as only one is shown on the images, but there’s 5 bulbs connected to that circuit, along with the bypass.


#7

I had a similar problem, Fibaro Dimmer 2 + Bypass on a light with four globes.

After buying several globe brands, and messing around a lot. I found the best solution (for me) was to simple remove two of the four globes, it now gets dim enough for me, and I am lucky that you can see the (lack) of globes.

Wife is not aware I removed two of the four globes from her new lights …


#8

Haha - that’s one way to fix it :smiley:

However my installation is downlight spots on the ceiling, so they’re kinda hard to miss

I just tried to remove the bypass since that shouldn’t be used in leading edge mode according to the fibaro manual, but that only makes the bulbs flicker as well.


#9

Exactly. Those Philips Hue spots are a bit estatically handicapt so if you can sink them in a ceiling or cabinet it’s perfect, but not if you see the spot itself.

As for the dimmer: The power usage is too small for the used dimmer. (the bypass should assist in that, but 5 watt is really very little so that’s hard to dim) You could try something with a small resistor to absorb a little energy (to put some load on the dimmer) but I’m not sure if that’s something you can do with this types of dimmers.


#10

I’d love to put in Hue lights, but there’s more than 75 spots in total in my house, so that would be approx. 4000 Euro, that’s way too much for my budget.

I have several groups, and the smallest group - the one I tested on - is 5 bulbs. So the smallest cummulative load using the Osram 3.5W bulbs would be 17,5W. And then the bypass on top of that.

I talked to the Danish distributor, and he claimed that he’d run a single 5W bulb with a bypass without any problems.


#11

I recently installed a Dimmer 2 (without the Bypass). The problem I had was that during installation (first time connecting and power on the Dimmer 2) auto-calibration was performed by the Fibaro Dimmer 2. This auto-calibration led to not being able to dim low enough just as you describe.

Now on to the problem. During the auto-calibration parameters 1 and 2 are set in Dimmer 2 (“Minimum brightness level” and “Maximum brightness level”). However, Athom Homey just assumes default values in the GUI instead of reading out the actual values after calibration, e.g. 1 and 99 is shown even if auto-calibration led to values 14 and 77.

So try to change “Minimum brightness level” to 2 and save. This helped me being able to dim really low. :slight_smile:

If there’s no difference in dim level between value 2 and let’s say 10, then you can set 10 as minimum value and so on until you find your perfect value.


#12

I’m also stuck with the fibaro dimmer. 1 got 1 working on 1 ikea regular led filament bulb, works like a charm all the way up and down.

I also have 3 garden lights. Put a fib in and can’t get it to work. Lights Wil only flikker or won’t go on at all. The auto settings also gave me a strange min/max range but adjusting them manually only led me to being able to put them on very bright. When I went down on dimming it would go a some way and then poof off.

Now when i remove 2 out of 3 lights it would work just fine. So that’s actually better performance with less watt, even less then 5. At this point I went all crazy and lost my patience, started removing my fancy dimmable led bulbs and putting back the old regular ones. I paused after 1 bulb to try it again and hey pronto works like a charm. So now I got 2 leds and one old fashion bulb and it just works. Seems fib doesn’t like multiple ledbulbs in 1 line.

It didn’t try the bypass yet. It’s a couple of weeks ago now but after a day of getting on and off a ladder to switch bulbs and wiring to see if I could find something I did wrong I still can’t get myself to start working on it again. :sweat_smile:


#13

Just to understand correctly - so now you have 2 dimmable LED and 1 normal halogen bulbs?

Doesn’t that look weird?


#14

Not halogen, just the regular filament. It actually doesn’t draw attention. The light temperature is quite close, barely anyone has noticed. Still want to replace it with the fancy led though because i see it everyday.


#15

I have no problem running a Dimmer2 + Bypass on a single LED with a power usage of 2.3 W. It runs 24-64 brightness. (worth noting that even with a min value of 24, I don’t notice any visual difference when the dimmer is on 5% or 15%).

I only mention this to debunk the theory that it is a power usage issue problem.

What are your read outs for min/max brightness for each of the globes after calibration?


#16

They were always 1 and 100.

I did some more tests where I hooked up an oscilloscope to the dimmer output, and the waveforms confirmed what I saw in the brightness test.

The RMS voltage at 1% brightness was approx 20V in leading edge and 40V in trailing edge.
So it’s not that strange that the lowest level in trailing edge is much brighter.

You can see the values and waveforms HERE