Homey Community Forum

Domoticz app

Downloaded the project from Github and changed the next lines in device.js

            case CAPABILITY_CUMULATIVE_POWER_HIGH:
                if(data.hasOwnProperty("Data") && (data.Data !== null && data.Data!=="")){
                    value = (DomoticzDevice.getMeterValue(data.Data,"T1"))/1000;
                }
                break;
            case CAPABILITY_CUMULATIVE_POWER_LOW:
                if(data.hasOwnProperty("Data") && (data.Data !== null && data.Data!=="")){
                    value = (DomoticzDevice.getMeterValue(data.Data,"T2"))/1000;
                }
                break; 

Then start the App by CLI

Please ignore my previous comment -> a Homey restart fixed the issue :laughing:

Ok, thanks…i will leave it as it is for the moment. Maybe a project for the future :smile:

I installed the app. Thank you for the app.
It functions good until I change the set point for a thermostat.
When I change the set point, I get a message, the app stopped working.
And the thermostat set point is constantly changing from 19 to 21 to 20 and so on.
Also in domoticz I can see it is changing.
Do you know what might be the problem?

Hi all,
After updating domoticz to version 2020.1, nothing works in Homey anymore, I have lost my sensors.
Do more people have this problem?

Did you restart the app/homey?

Yes even uninstall and reinstall the domoticz application.

After installation, the hosname, port, username and password of the admin of the domoticz but I don’t see any sensors appear in the box below.
I can only save and back

Haven’t updated my domoticz yet so haven’t got time to check it. Maybe this weekend

never seen devices in this box but are they also not visible in Homey Devices?

I completely reinstalled my PI and domoticz and now I have my sensors visible again in Homey.
Thanks.

Hi, For a few months I have a raspberry pi installed with Domoticz. I completely reinstalled it 10 days ago after an update to Domoticz 2020. It’s working and I have installed the P1 smart meter cable. This week I bougth a Homey and try to install the Domoticz app. Whatever I put in the parameters I can not connect. I know the IP-address is correct because I can access the Domoticz panel. What should I use for port? the default 8080 also used to access the panel, or the ’ remote shared port’ which is in the settings, or nothing at all? And for login? the deault user/password for the pi? or a user defined in the settings of Domoticz?

image
this is all I dit for setting, no name no password.

thanx, but didn’t work for me. could be because it is not static ip but by dhcp?

As long as you can connect to the IP via your browser, it also should connect to Homey.
but what is exactly not working? Where do you expect something?

I get a timeout error (after 30 sec.). Should I configure the Domoticz? I see under settings, more-options the possibility to send data through http; do I need to configure that? The only hardware I have connected is the P1 msart meter cable which gets me Voltage L1/l2/l2, Usage L1/L2/L3, total, Delivery l1/L2/L3 (solar panels) and Gas. Besides that I have nothing configured.

Normaly there is nothing to configure, maybe a restart of the app or Homey can help, otherwise ask @Jeroen_Somhorst

Hi Jeroen,
Thanks for the app. The installation and configuration worked fine, but I’m only able to get T1, T2 and current power values. I’m missing the return values R1 and R2. On the domoticz side I can see them just fine. Is there something I’m missing or did wrong?

Hi,

This is not implemented

anyone willing to take this app over from me? As you may have guessed i’m not that active anymore and I would like to give the app/source to someone who can / want to work on it

1 Like