Homey Community Forum

Domoticz app

Hi Jeroen, think Pascal wants the total “meterstanden” , I also would like that very much, even more than the current dayly totals.

Yeah already thought so myself. I will check if I can retrieve that somehow. I will keep you updated.

1 Like



Something like this?

1 Like

Very welcome!
I’m very happy with the progress of your app!
Its a perfect way to read out a smart meter with Domoticz!

Not something but exactly, great job, thanks very much :slight_smile:

What is Ring for on top of Gas page with slider?

that’s nothing. That is something from my phone… it sometimes does that when I try to take a screenshot

I just updated github repo so for those who are brave. Install it from there. Also keep in mind that you need to repair the devices for this to work.


Keep up the good work!

Just got the update through the regular app store, works great! Was wondering if you could add a decimal point to the electricity t1 and t2 like the gas meter?

Great if i would get it to work. I have Domoticz on synology and that all works, but i cannot get it to work in homey it reports there are no devices configured yet.
What am i doing wrong? In the app i put the ip address from the domoticz server and the port 8084 on which i can see the domoticsz web page.
What am i doing wrong?

I’ve send you an PM

got it installed also now. It gets the gas and electric meter, but it is not showing any values.
while on domoticz it gives values.

i just needed to wait, now data is showing.

1 Like

my domoticz app on the homey does not work. how do i install it and do i have to install something on my raspberry/domoticz or not?

You don’t need to install anything on your domoticz. If you installed the app you should go to more -> settings -> scroll down to the apps section and select domoticz app. You need to provide the following:

  • The url / ip adres
  • the port to connect to
  • username
  • password

and then hit save. Next you should be able to add new devices. By going to the main screen of the homey app and go to devices and hit the + button

Hi Jeroen,

I installed the current and the beta version, but have issues getting it to work. Using the IP and the external address, with correct credentials I go thru the wizard and get “no new devices”. If I use the ip/url with port an same credentials in Chrome, I do get a connection.

Your earlier version worked for me, I was trying to test the latest releases.

I cant get this to work
I try to connect with same ip and port as I do in The domoticz app, username and also The same password but I can not hit The save buttom, nothing happens, anyone know what Im doing wrong?

I’m currently working on the app again. As @Eternity correctly stated the app is currently a tiny bit broken :wink: . Don’t know when it will be fixed but i’ll keep you all updated.

In the next version of the app I would like to introduce a new functionality. To group ‘devices’ together. Currently when the app scans domotics it will let you show every single device as a single device. But in domoticz it could belong to the same hardware. For instance I have a P1 smart meter. Currently when i add it using the app it will show up as two separate devices in Homey. But in fact its a single device with two capabilities.

Before I make that change I would like to know what you all think about this. Keep it as it is now ( fixed )? Or group devices based on the hardware it belongs to?

1 Like

Using version 0.1.4 beta and this version does the job for me. I switched in most flows from HTTP app to Domoticz app.
Plessers keep it this way.
So thanks for this app.

Gave the App another try. Tried the stable and the beta, but both don’t install devices for me. Will try again this weekend.

Why I installed the App again?
I have plans to set up a separate domotica system, controlled by a Xiaomi gateway. This is for my sons bedroom, and allows him to experiment.
We both can see the devices in the Mi App and in Domoticz (on my NAS), I thought that linking Domoticz to Homey would allow me to control the gear connected to the gateway