Homey Community Forum

Dyson control doesn't respond (but no error either)

In the book every day a new problem, this day: Dyson. My Dyson Cool doesn’t respond to the commands I sent from the Homey app. When I tried to repair the device, logged back in, it worked until it didn’t work again.
From the Dyson app it does work, so it’s connected. It just seems that the Dyson app is once again broken!?

Anybody else got issues? Or better: tips? :slight_smile:

Never got it working with the Dyson app. Eventually got it working, but not a nice way though. Harmony app was able to ad my Dyson, but on/off didn’t work. So i added a smart plug. It works, but not the easiest way.

Some weeks ago, Dyson changed the API as they intoduced 2FA. The HomeAssistant integration stopped working, too.
Some new forks were created to get it working.
The solution until this week was, to open the Dyson app for forcing Login and then restart HomeAssistant. But this is not working anymore.

Perhaps that’s the problem with the Homey app, too.
In that case, the developer should check if the 2FA could get to work. I’m not sure if it’s possible because the Dyson API is not open and only implemented on bas of reverse engineering (so far my knowledge about it).

With the introduction of 2FA, i restart the dyson-app once a night. So ist works without problems. Missing Options like Night-Mode and the full integration of Dyson Humidify+Cool.

Restarting apps every night seems like a typical homey solution. Probably we should report this Athom, as they are the developers of that app.
I feel that I have had it with the lame support of all the homey apps. Every week there is something not working here…

1 Like

Have had an Issue with Athom-Support for Dyson-App through 2FA. Will make a Follow-Ticket.

All other Apps on Homey running during the last weeks fine.

And? Curious about Athom’s fix

Made a new Ticket some Weeks ago. Also asked for the Option „Night-Mode“ in this Ticket. Got this (a part of it) back:

I have added your requests to our list of requests but I could not make any promises about if or when your request would be implemented. We focus mainly on the improvement of Homey itself and we have only limited resources to create apps or add new features and our development roadmap is already huge.

It is now more than 5 monty ago and nothing happend. The same BlaBlaBla as i heared often. Support sucks, App-Updates are very slow.

Thanks

On ioBroker found these information. It seems to be something from Dyson-Api when you‘re using different Apps like Dyson-Company-App and Homey to control your Dyson(s):

  • wait a while (up to an hour or maybe more since dyson has a blocker for too many requests in a short time frame)*

So you need to restart sometimes the Dyson-App on Homey to re-login to your Dyson-Account.

Issue is definitely 2FA.
I have just purchased a Dyson Fan. Purposely because it was meant to work with Homey.
Just to find its broken. :sob:

When I first try to login, I get cannot authenticate error.
Then I log out of Dyson official mobile app, go to log back in and before I sign in with the 2FA pin code or just after I sign in with the pin code.
I then try the honey app again and get “Could not find that PairSession” error. Hence it is looking for the key from 2FA authentication.

I hope Homey team fix this soon :sob::pleading_face: