Homey Community Forum

Elgato StreamDeck Integration

thanks for your response
I uninstall the plugin in stream deck + trigger Homey but it still doesn’t work

@DinoRayn hm. That’s strange. I had a quick look at the code in the meantime. The error is thrown whilst parsing the data coming from Homey. Could you send me a diagnostics report for the Homey app? I’d like to check whether the response actually is sent from Homey.

Upcoming v1.2.2 should fix the issue you been seeing @DinoRayn. Seems it caused by a non existing capabilities object causing an error on Homey side. Hence the strange error showing in the plugin.

hi,
Sorry, i was absent. the test version works well thanks!

1 Like

Hello, thank you for creating this plugin. I’ve been trying for some time to get it to work for me, but I keep getting the message. I keep getting the message

“ERROR: Cannot connect to Homey! Please check the app FAQ on the Homey community forum!”

I’ve tried using the hostname supplied by the app and have made sure it is typed correctly. I have also tried the local IP address, but keep getting the same message. I have tried simple keys and complex keys. I don’t know if there is a specific requirement for key length or not.

I’ve also tried to add another tile in streamdeck and back to the original tile eliminating the refresh.

I’ve also pinged homey from my machine and I get a response.

Not sure what else could be wrong. This is on a MacBook Pro, but I have also had it when trying my iMac too. I did also try a windows virtual machine and same result.

Any help would be appreciated.

Thanks

Resolved using cloud ID

Hi @vip,
this is rather unusual actually. If it works through cloud but you can ping homey directly, it should also work locally. But glad it works for you.
Just ping me if you need further assistance.

Hi! I have to this day used the application on PC but I recently moved over to Mac and I can’t get the plugin to work. It won’t connect to the homey. The pc still connects perfectly and works as expected, anyone that has experiences with Mac and this plugin?

Best regards
Sondre

Hi @SondreM,
sorry to hear you are having troubles. Whilst I have no Mac I could test the app on, it is written platform independend. So it actually should work just as fine on the Mac StreamDeck app.
I assume your Mac has proper internet access. Have you tried to use the cloud address for the Homey hostname? (see FAQ) If it works via cloud then you most likely got an issue with your local network. (Firewall, vLan, or anything mingling with TCP/IP protocol)
Maybe one of the other users can help you with Mac specific things.

Have a nice weekend

1 Like

Thanks for quick answer! It works through the cloud so it is a bit weird. Same network but it works on the pc and not the Mac. Need to do some troubleshooting on the Mac.

1 Like

@SondreM Alright. Please share what you found out. It might be helpful to other Mac users. Or maybe I could even add something to the FAQ.

This is awesome. Thank you for the great integration!
Would it be possible to launch a flow directly without having to do it via a trigger?
That would save me a lot of small flows

1 Like

Hi @Peter_Thornton,
Glad you enjoy this app :smiley:
Unfortunately it is technically not possible to launch flows. This is a limitation of the App SDK.
It would be possible thru the Web API. But that part has not been released for production use, yet.

Ah. Let’s hope they get the Web API ready soon then :slightly_smiling_face:
If the app allowed you to start a flow by a parameter/tag that could fix it as well (and would fix a lot of other issues I have as well) but I don’t see that happening anytime soon.

That isn’t true, If you contact Athom then they can give you keys for the web api, this has already been done several times now (like for the wearOS app)

1 Like

Oh. Good to know. Will put that on my to do list :smiley:

hi @Shakesbeard,

I have a problem. I formate my macbook and re-install StreamDeck plugin. But the connexion is impossible enter streamdeck plugin and streamdeck application. My informations are correct (i checked 50 times …)

I tried with IP adress, homey cloud adress (homey- …); i have changed password… But don’t working.

The plugin is online ?

Hi @DinoRayn,
well that indeed is a bit weird. So the cloud address should always work actually. If that is not working even then please try/check the following:

  • Ensure the StreamDeck Integration app on your Homey has not stopped working for any reason.
  • Restart the StreamDeck app on Homey, just in case to make sure the api listeners are reinstalled if for any reason Homey ran out of handles.
  • I have noticed in some rare cases that the StreamDeck does not properly install/update the plugin. Try uninstalling the plugin and install it again.

The plugin should be working fine. There have not been any critical updates recently.
Let me know whether above helped please. Also feel free to send me a private message on the forum if not. We might need to dig deeper into this and analyze the issue if it persists.