Homey Community Forum

"En" flow werkt niet meer

Goede middag,

Ik heb problemen met de EN stap in flows.
Ik heb in de EN stap een deur sensor zitten en als ik op test in die flow druk krijg ik bij die deur sensor een rode uitroepteken.
De sensor doet het wel want hij staat ook in een andere flow dat als ik thuis kom binnen een bepaalde tijd dat de lichten aan gaan, dat doet het dus gewoon.
Nu dacht ik als ik iets anders in de EN stap zet wat er dan gebeurt. Dus ik had het omgedraaid, dat als de sensor aan gaat EN er is niemand thuis… dan krijg ik weer bij de EN niemand thuis een rode uitroepteken.

Weet iemand wat hier aan de hand kan zijn ? Heb ik misschien iets veranderd waardoor dat niet meer werkt ?

M.v.g Robert

Dat uitroepteken krijg je te zien als de conditie waarop je test niet waar is. Dus de deursensor stond niet open of er was iemand thuis.

Ik heb het net getest en het klopt. Als ik iedereen " uit huis plaats " dus op afwezig zet doet ie het wel. Maar dan klopt het weer niet dat de sensor aan ging wat ik heb de deur niet bewogen. Het zou toch gek zijn als je met een test alles zo moet zetten dat alles waar is. Dan hoef je het ook niet te testen. Maar gewoon uitvoeren. Of zie ik dat verkeerd ?

M.v.g Robert

Bij tests wordt sowieso niet naar de “ALS” kaart gekeken. En als je níet alles zo moet zetten dat het waar is, hoe zou je dan de negatieve uitkomst kunnen testen?

Het enigste wat de “test” optie doet, is de trigger (als) vervangen.

Verder test die de flow zoals jij hem hebt geschreven. Homey kijkt dus nog steeds of je voorwaarde (en) kloppen.

Dus als jou voorwaarde (en) is “lamp is aan” maar in werkelijkheid is de lamp uit. Dan krijg je het uitroepteken.

2 Likes

Oke duidelijk. Bedankt voor de uitleg.