Homey Community Forum

Enigma2 DVB Boxes Support

app
official
v2
#21

Is anybody willed to translate everything into NL? If so, please contact me and i will also mention your help!

0 Likes

#22

some feedback…

Sadly it does not work on homey 1.5.x, not one of the action flow cards work.

Then there is a little issue adding the device itself
Normally you press the + in your device list to add a new device and you choose here the app of the device you wish to add, this option is not available in this alpha version.
At the moment i had to change the settings in the settings part of homey.

This way to add the device limit the app to control only 1 enigma2 device per homey, if you add it as separate device you can control more enigma2 devices with 1 homey.

Also there are no IF & AND flow cards available, so creating a flow like:
if flow is started AND enigma2 power is ON THEN turn of LIGHTS
is currently not possible, i hope your will add this in future releases.

The IF cards can be a challenge but the AND card should not be that difficult, you only have to poll AND cards if the flow is triggerred.
Tip see how the KODI app has solved this problem, this app does almost exactly the same as your app only with an other device, kodi instead of enigma2 device.

0 Likes

#23

@B3rt
Thanks for the feedback. More cards are allready planned. But this needs time.
I currently only support the way you describe it, because it was easier to see, if it works with different boxes and if it works from homey in general. The device implementation via a device add is still on the list.
Did you get any errors when a flow is started? Would be interesting to see, I can’t imagine, why it should not work with homey 1.5.13 because the sdk2 is allready supported.

The config u entered is correct? And also you hit the save button and when reopen the site, your data is shown as entered previously?

0 Likes

#24

Settings are present when the screen is opened again.
The IP and port are correct, when i visit http://ip.entered:port is get the webif interface of my enigma2 (vu+ ultimo 4k)

When i trigger a flow card it gives as green V in the card that it has be executed but nothing happens on the enigma2 box itself, there is also NO error etc, just nothing happens.
When i use homey login also nothing is recorded, no logs etc.

0 Likes

#25

That is strange, can you check the following:
open your browser and go to this location:
http://IP_OF_BOX:PORT/web/powerstate?newstate=5
should bring the Box to standby
http://IP_OF_BOX:PORT/web/powerstate?newstate=4
should bring the Box to wake up
If these both should work, then the code should work as well, since this call is sended from my code.
also it would be helpful if you can send me a screen or the source code of the output from following call:
http://IP_OF_BOX:PORT/web/about and http://IP_OF_BOX:PORT/web/deviceinfo

may i ask you why you are not yet updated to the newest version of the Firmware?

0 Likes

#26

The reason is that i did not update yet is because version 2 lacks the desktop option, i have a lot of flows and controlling homey only on a phone cannot be done, for a good working / programming a desktop interface is needed. The did release a desktop flow editor but it does has still some flaws in it. I update when version 2 is stable enough and athom has added /fixed al bugs and problems of version 2.

Regarding the enigma2 box, the box works and respond on http request, i do this already by http request flow cards

Here is the output requested:
[quote]
e2abouts>OE-Alliance 4.22019-02-26openatv6.2.020190104OWIF 1.3.60Ultimo4K00:1d:ec:10:5b:fdTrue192.168.1.5255.255.255.0192.168.1.1ATA(Samsung SSD 840)232.9 GB155.0 GB/media/hddTuner AVuplus DVB-C NIM(BCM3148) (DVB-C)Tuner BVuplus DVB-C NIM(BCM3148) (DVB-C)Tuner CVuplus DVB-C NIM(BCM3148) (DVB-C)Tuner DVuplus DVB-C NIM(BCM3148) (DVB-C)Tuner EVuplus DVB-C NIM(BCM3148) (DVB-C)Tuner FVuplus DVB-C NIM(BCM3148) (DVB-C)Tuner GVuplus DVB-C NIM(BCM3148) (DVB-C)Tuner HVuplus DVB-C NIM(BCM3148) (DVB-C)Tuner IVuplus DVB-S NIM(45208 FBC) (DVB-S2)Tuner JVuplus DVB-S NIM(45208 FBC) (DVB-S2)Tuner KVuplus DVB-S NIM(45208 FBC) (DVB-S2)Tuner LVuplus DVB-S NIM(45208 FBC) (DVB-S2)Tuner MVuplus DVB-S NIM(45208 FBC) (DVB-S2)Tuner NVuplus DVB-S NIM(45208 FBC) (DVB-S2)Tuner OVuplus DVB-S NIM(45208 FBC) (DVB-S2)Tuner PVuplus DVB-S NIM(45208 FBC) (DVB-S2)SBS6 HD42949017603Ziggo192010801920x1080471247014701470048012059153619130
[/quote]

0 Likes

#27

This seems strange to me, all i do with my code is to send a request to the correct address and dynamically build the Address that is “loaded” if the address itself is working normal and you don’t have setup an Username or Password and don’t use HTTPS calls then it should work. I don’t think that the driver itself is causing the issues, but i will try to get a version online for you to test that provides a bit more feedback and a log to be downloaded with all sended commands in it. If you are ok with it. I promise to not misuse the information in any way!

0 Likes

#28

there is no user/pass needed on my vu+ when connected using http://, only when connected to https:// then there is a user/pass needed.

0 Likes

#29

@B3rt I’ve just Updated to Version 0.0.9 with this Version a Consol Output for false responses from the Receiver is implemented. The only issue here is you need to install the App via the Athom CLI and then send out Test calls, if you are willed to do that, i can recheck what is going wrong with your calls. Only thing then needed is the Output of the consol if there are any faults.
If you are not familiar with the Athom CLI or you don’t like toi do that, i’m ok with that!

0 Likes

#30

I’ve again Update the App to Version 0.1.0, in this Version all Calls and actions are logged. This Log is now included when you create and diagnostic report.

So if somebody has Issues, do not hesitate to send a Report (it includes the Logs for better understanding what is happening).

Thanks again for everybody who participates in this tests!

0 Likes

#31

Whoa, one of those apps you didn’t realize you needed until you see it! :smiley:

I’m a (very) experienced Enigma user and can really appreciate this! Just never thought of using it with my Homey for whatever reason…

Anyway, I am Dutch. I am more than happy to support with translating to Dutch from English if appreciated. Please hit me up in that case :).

0 Likes

#32

@Martin_Timmermans If you like, you can make it. I previously used google translate but get rid of it, due to reasons.

@all
I observed, that in the current Beta Release that is publical now is a fault when using the Message Flowcard. This will be solved with the next Version (this needs aprove by Athom).

Currently i’m at the first and / condition cards, as sonn as the first card is working correctly, i will push a new Alpha, if you need to use the message function, this will then be also fixed there!
Sorry for the inconvinience, there was a typo due to last minute changes…

0 Likes

#33

Happy to do so. Where and how do I start? :slight_smile:

0 Likes

#34

You need the following files:


these are used to get the language made correctly. For the first File you see the following lines:
“en”: “send command as ID”,
“de”: “Kontrollbefehl als ID senden”

you need to add a , after the de line and write the following for each entry:
“nl”: “TRANSLATED TEXT HERE”

for the second file, just make a copy and name it nl.json
In this file you need to translate everything that’s in the second " XXX" section. The first “XX” is always the name of the location.
If you have questions, do not hesitate to ask. And thanks for your Help!

0 Likes

#35

Done. Please find them here:

1 Like

#36

I’m right that the app does not support the et10000 and the dm8000?

0 Likes

#37

@Ben
As far as these Boxes have openwebif installed it should work.
In the currently available beta of the app, there is a typo in the message section, so this fail. A fix is allready on the way, but needs approval by athom before I’m able to publish it.

0 Likes

#38

I have put in the IP-adres and i filled in the Port in the app of Homey and i tried to safe the configuration but nothing happens. In the app he stays on saved configuration.

0 Likes

#39

If it stays on the saved config, everythign should work. Then u need to go an create a flow with the Then card. the Current version only support the then cards. I’m currently building some and cards. But i didnt had much time the last days.
If the cards then not perform any action, please let me know. Then i will check, you can then provide me a diagnostic report and i check why it is causing issues. Only card that is not working is the message card, as mentioned previously.

0 Likes

#40

You are right. Thanks. But i have one question. Now is it possible to have or to set one configuration , but is it possible for more mutiple configurations or boxes?

0 Likes