Homey Community Forum

Eurotronic Technology App (Stable: v2.0.6)

Hi, gonna jump in here:
My thermostat is behind a curtain. It gets of course wrong temp values there so I want the Aqara Temp sensor of the room to send its temp to the thermostat.

The device ID of the Aqara is 24321. The number is to long to be added in the association field.
2.) I made a flow: when (Aqara) temp of Aqara changes, then (thermostat) “send room temperature”. Doesn’t work.

Use external temp sensor is checked as “on”.

Is it me or the software?

1 aqara is zigbee, so kinda obvious to not be able to direct association 2 different frequencies and protocols.
2. What doesn’t work, do you get an error message?

1.) Ouch :smile:

2.) Nah, it just doesnt do what it’s supposed to do: Handing over the temp value when this changes

Do you have multiple thermostats?

Indeed - 3, but only 2 installed.
The first one works with it’s internal sensor but I am looking to let the 2nd and 3rd one is external temp data.

and how do you know it is not working? if you look at the measure temperature in the app, then you’re wrong, as that is just the last measure temperature from the valve itself

Well the temp sensor has 19.1 degrees and the valve shows 16.5

If the temp value in the valve shown is not the temp from the sensor - though my flow says when temp changes, send temp to valve - then how could there be any way to be sure that it works?!?

There is not, even if I try to verify it by fetching it from the valve, I still get the last measured temperature of the valve itself.
I could fake it by setting the send value as the measured temperature in the GUI, but that would only be a placebo.

You’ll just have to see if the valve closes when the temperature is getting near the target temperature.

Hmmm then the function is useless and not working?

When looking at the web dev app I see the same, „ measured temp“ with a value of 16 degree (which is definitely neither the correct room temperature nor the value of the Aqara sensor).

My understanding of that feature is afaik correct: Use an external sensor instead of the o thermal sensor.
But that has to be shown somewhere as the device needs to work w/ that external value?!

Perhaps I might wanna contact the dev?

Wake up call, I am the developer :wink:

There is just no way for me to sync the external room temperature to homey vs the valve.
I’ll repeat:

There is no way for me to sync homey’s state with the valve when using a external temperature sensor.
It does work.


:smile: sorry, I didn’t notice. :face_with_hand_over_mouth:

Okay - first of all - Again: I highly highly appreciate how you dev guys put so much effort in such projects and even maintain that - don’t you sleep sometimes? :exploding_head: :man_superhero:

… so just to get it really right and due to I am very curious and interested in that technology
The flow is correct as:

WHEN external sensor (value Tag temperature) changes
THEN valve: send room temperature (value tag temperature of external sensor)

This flow then works around for the missing capability of the hardware to overwrite the shown temperature value; ergo the temp shown on the valve page will always be the measured temp of the valve - and there’s no way to change that. (Could Athom “allow” that to get changed in a future update?)

Sleep? :thinking: Can you eat that?

The external room temperature is by design only meant for direct association, so a temperature measuring zwave device directly sending the value to the valve.
(And then the value of measured temperature of the valve itself should be hidden in the GUI, though that is not possible in homey unfortunately)

But as homey is capable of receiving so many more types of temperature receiving devices (zigbee, wifi, Bluetooth) I’ve added a way to “simulate” this direct association inside the app (in the form of this flow card).

Though this external temperature (doesn’t matter in what way it is being send to the device) is just not possible to be read out from the valve for some reason, this is a limitation of the valve itself and is not something homey (or athom) can change.
I could add internally, that the value that is being send via the flow card is then also the value of the measured temperature shown in the GUI (not something I thought of right away, but is also a bit of a placebo effect) though that still wouldn’t catch if an direct associated sensor would send that value either.

1 Like

v2.0.4 is awaiting for approval by Athom in the app-store (beta channel).

This should fix the wrong device (the last one included) being controlled by flow cards.


Thanks for all the work you put into this!

1 Like

Yes, thanks Guy!!

Btw- I installed the 2nd valve again today and the app is neither showing temp nor Color. Re: DevApp the device is fine and routed. :thinking::man_shrugging:

Had the same yesterday but there was a black circle :black_circle: with 19 in it. Was that the economic Mode? :thinking:

If there is no measured temperature, then homey will not know if it is heating or cooling (target temperature higher then measured = red, lower = blue, the same temperature/no measured = black)
The thermostat mode has no effect on this.

BTW, I have no control over this behaviour, as a thermostatic can not cool so a bit weird that it turns blue, I know, nothing I can change about it.

Yep, I checked and it is indeed reporting 100% battery level!

V2.0.4 is now available in the beta Channel of the appstore.
Hopefully this will be the last beta before putting it to stable, let me know your findings!

@Caseda you seem to have solved the problem. 2.0.4. Installed one hour ago and the right thermostats responded to the triggered flows. Have 6 thermostats installed with (per thermostat) 2 temperature setting flows (day and night schedule) and two flows opening or closing the valve in manual mode depending on the measured temperature. Seems to be working like a charm. Thermostats also report the % open like they should. Big thank you!



Could you please explain why and how you use this?

Thank you!

Great work @Caseda