Homey Community

Eurotronics Spirit thermostat valves not workin

z-wave

#1

I installed 5 Spirit- valves, and have big issues getting these things to keep the temperature.

In sleeping rooms I put them on 16 Celsius, but almost always the room is heated up to 20.

Even when I put it in OFF, it closes for a minute or two, and then opens again.

There are no flows.

I completely reset the z-wave, and included them perfectly, before I had some erroneous inclusions, so I took that away.

The settings I do in the app show up on the LCD display perfectly.

But I burn tonnes of gas needlessly?


#2

If I understand you correctly this is an issue in your heating cq the Spirit Valves that even when it is off it opens the heating and even when it reaches more then the 16 degree it still keeps the heating open.


#3

I once noticed that my valves were in an ‘off state’ and did not accept commands but remained in the set temp position. I resolved that by sending some test flows to them, changing the temperature and putting them in the ‘comfortable’ state.

As @Dijker also says, I think this is not a Homey issue, but heating / valves issue.


#5

Can you confirm that if you change them manually that you can see the new setting in homey? My point is, can the valves reach homey?

I resolved my connectivity issues by installing a few smart plugs in my house. Homey’s antennas are pretty bad and by installing one smart plug near homey, which automatically started serving as a zwave router solved all of my issues. I am a very happy Spirit valve user :slight_smile: