Homey Community Forum

Eurotronics Spirit Zwave Plus

Hello,

I have 6 Spirit Zwave Plus and I have a problem with the battery level report. in https://developer.athom.com/tools/devices, for all Spirit devices the last battery measurement over 2 months. Even when changing the battery the value of is not updated.

Thanks for you Help

There are already several posts with this problem, it seems to be a Homey/Z-Wave protocol problem. Please contact Athom.

Well actually for eurotronic spirit the issue is a device issue (useally after changing the battery once that it stops reporting the battery level), that some spirits have, nothing me or Athom can do about.

You’ll have to try and contact eurotronic about that.

Is it related to a spezial Firmware Version?
Because all my Spirits are reporting the Battery level as they should, even after changing battery!
I’ m not using homey anymore. But if it is a device issue the problem should also be present with other gateways, or not?!

it isn’t related to a firmware version (unless they used the same version number for 2 different firmwares…), definitely seems a hardware issue, like the temperature overshooting that some spirits have (not closing fast enough, or even at all).

But I also said it isn’t with all spirits, the app has over 750 users, and only 5/6 users have mentioned it now (in +/-2 years of time), like I have 2 and both still report their battery value(s) like they should.

The fact that the battery capacity is partly reported and partly not is the same with other devices. Some users have the problem, others don’t, with the same hardware and firmware.
I have 3 NEO Coolcam Motion sensors with exactly the same hardware and firmware. 2 sensors have updated “measure_battery” 5 months ago (probably during installation), 1 sensor has updated the status 2 weeks ago.
And that should be caused by the hardware? Are you sure?

This topic is about the eurotronic spirit, I have a lot more inside information about this particular brand cause I develop the app for them, not sure how you can put a totally different brand under the same header here.
Not every brand has this, only neo coolcam (no clue how bad, but seen it many times) and fibaro (they ignore 60% of the battery level calls Homey sends, this has been verified with a (non Athom) z-wave sniffer) come up most of the times.

I have yet to see a NodOn remote not report its battery level, nor an Aeotec device.
Neither for the older thermostatic versions of eurotronic, and the newer temperature/humidity sensor (though that is still too new to get a proper assessment for).
So it is different for every brand there is.

Oh right: the biggest difference is the way of reporting.
Eurotronic, nodon and Aeotec send it either on an interval or change threshold, fibaro and neo coolcam need to be asked what their current battery level is, they don’t report it on their own.

This topic is about problems with the battery capacity readings of Eurotronic Spirit thermostats, that is correct.
But inmo it doesn’t matter that I mentioned NEO Coolcam. I just wanted to point out that the battery capacity problem also exists with other devices.
My question is if the problem is caused by the hardware, the app or by Homey Z-Wave code.
So I don’t think my post is OT. If my post is considered OT after all, then I apologize for that, sorry.

As admin you are free to delete my post.

Hi, me i have the same problem with
AEOTEC ZWA021 Radiator Thermostat - Tête thermostatique sans-fil Z-Wave+ (same as Eurotronic Spirit)


I have just change the battery
But it’s only 25%
Nobody have a solution ?