Homey Community Forum

Everspring overall support topic

This is the official support topic for the Everspring app.

Right now, I am completely rewriting the app to comply with all the new guidelines that Homey requires these days. Hopefully that will also solve some weird issues that are starting to pop up.

To determine priority in rewriting, I have created a poll. If you are a Everspring user, let me know which devices to work on first. There poll is here: https://www.strawpoll.me/20097735

I will also need volunteers to install the test version. As I don’t have all the Everspring devices myself, I will not be able to fully test all devices. So your help is appreciated (and will increase priority :wink: )

As always, donations in money and/or hardware is always appreciated, and will also help the support of the development. Donate here: https://www.paypal.me/ralfvd , please leave a note in the paypal remarks that it is for Evernote, and maybe for a specific device. Again, priority :wink:

If you’d like to donate hardware, permanently or temporarily, send me a private message and we will discuss this.

I will update this topic as much as possible. Let me know any questions. Thanks for your patience!

6 Likes

Hi, after a long silence, the rewrite is somewhat complete. you can find it here: https://homey.app/nl-nl/app/com.everspring/Everspring/test/

As I immediately upgraded to SDK-3, you will need Homey 5.0 for this.

As I don’t own many of the implemented devices, there will be issues; it is a complete rewrite and it is certain I missed certain quirks; Everspring is not ‘standard’.

Please report the issues and I will try to debug and fix them.

If you do upgrade to Homey 5, you will need to install this test version, since the old app (on SDK-1) will not work on Homey 5.

I love hearing your feedback!

3 Likes

Any chance of adding the EH403 flood light? Works fine in Fibaro HC3, but would like to add it in homey. The HC3 doesn’t work too well yet with all the rest…

Hi,

do the smoke detectors work in Homey V5

Hello,

In the testversion, the smoke detectors are implemented. But as I don’t own the smoke detectors myself, I haven’t been able to check them.

It would help me a lot if you could test them and report feedback. I ensure priority support to get it working for you (and therefor others) if it doesn’t work.

Install via: https://homey.app/nl-nl/app/com.everspring/Everspring/test/

Hallo @ralfvd

I still clarify 2 questions in the German forum and would then test it. I inform you. Many thanks

Hi! @ralfvd

The Everspring an-179, has 2 binary inputs.
Is it possible to get the status of these out?

Thinking about using it for my garage door.
Use the relay as a toggle. And would like to get the status of the door back via a sensor.

So then i can use the an-179 to open/close the garagedoor and get the status.

Hi, thank you for making this version. I have a problem with AN-179. It is not possible to set toggle as switch type?
Thanks
Previn

I installed the beta 2.09 now my device AN 181-2 is not responding to on/off and not reporting power usage.

Hi, add battery type for ST814
3 x AA

https://www.everspring.com/portfolio-item/st814-temperature-humidity-detector/

Hi Ralf I now have the same problem with a new motion sensor from Heimman. With that sensor I saw in the developers tool that a sabotage message was given in the event of movement. The SP103 also has a sabotage contact, only that does not appear in your app.? Could it be that in your app the movement is also seen as a sabotage.? Could it be that Homey has mixed up something in their zwave protocol?

AN181 is not working in v2.0.9.
Thanks!

Sadly no response from @ralfvd

I’ve made a chance for AN181 in v2.1.3 , it should be working now. If not, please submit a diagnostic report, so I can have a look at what is going wrong. Thanks for your patience!

Sorry for the delay, I"ve made a change for AN181 so if you update to 2.1.4 , it should work now. If not, please submit a diagnostics report, so I can have a look.

I am still working on the sabotage alarm. When I first included it (in one of the first Everspring versions), it was not working reliable. That was caused by a weird way of how the Everspring SP103 device works.

I am now giving it a second try, but don’t have the device myself, so I am relying on the community for feedback.

1 Like

I will happy to test is I have 2 non working at this moment

This app sadly does not work on v5

I used it with 3x AN158, after i got the v5 update today my 3 AN158 devices where completely gone from Homey, as well the app.
All the flows where the devices where used where of cource broken.

I found the beta version, installed it but sadky i cannot add the an 158 devices anymore.
When i add it, it is detected by homey and when i finish the adding process homey ends with a message that the device cannot be added and that was it…

I removed the devices again using settings and remove zwave device (following remove instructions) which Homey confirms it is done.
The tried to add it again but no success, adding the AN158 is simply impossible.

Hi @B3rt , developer here: sorry to hear you are having difficulties. Good that you found the Beta app, as Athom is now upgrading to 5.0 automatically, I’ve submitted this version for the non-Beta version. Hopefully it will be available soon.

I am not sure why your devices were not visible anymore after updating. But you should be able to re-install them.

Can you submit a diagnostics report via the app settings? Maybe then I can see what is happening in your case.

Thanks!

@ralfvd can you add support for the SP815 pir Unit ?
I see the SP814 and SP816 already.

Andrew