Homey Community Forum

Fibaro FGMS-001-PLUS, Motion Sensor (already added error)

#1

Is there a way to see and remove a device that is being reported as ‘already_installed’ when you try to add it but it doesn’t show on your list?

I purchased 2 x FGMS-001-PLUS, Motion Sensor (Z-Wave Plus) devices, first one added fine with the Fibaro App but the second one keeps reporting that it is already added. They do get a unique identifier each, I may hope?!

#2

A zwave device can only be coupled to 1 controller at a time, so if the device already thinks it is included to a controller it gives that message.
The only way to fix that is by resetting that device,
by either factory reset of the device itself. (see manual)
Or removing (which also resets) it via homey in settings -> zwave -> remove device

#3

I actually just managed to find it. The developer webpage allows you to remove any node and I was able to run that succesfully on the sensor by using the pairing action (tripple click button). It reported to have removed an unknown node and tgen I could add it succesfully!

#4

I could not remove it from the device pane as it was not listed there.

#5
Time Entry
2019-02-02T10:36:21.489Z Command[7] start: removeNode
2019-02-02T10:36:21.517Z Command[7] status: removeNode, status: REMOVE_NODE_STATUS_LEARN_READY
2019-02-02T10:36:24.004Z Command[8] start: removeNodeAbort
2019-02-02T10:36:24.009Z Command[8] end: removeNodeAbort
2019-02-02T10:36:24.065Z Command[7] status: removeNode, status: REMOVE_NODE_STATUS_DONE
#6

I never said to remove it from the device panel, as a device could also be included into another controller it has a very big chance not being in homey.

A good practice for zwave devices is to always reset the device to factory, even if it is brand new.

And as already said there are multiple options to reset the device, 2 I told you, the 3th one you found yourself.

Then of course follow the instructions on your screen, not just wait as that won’t delete anything.
how should homey know which device it would need to delete (/reset) so you need to let homey know by activating the removal/inclusion procedure of the device.

#7

Thanks, your solution is easier than mine indeed.

#8

I have similar issues… although it is saying that fibero is already added:

2019-03-25T20:47:24.392Z Command[121] start: addNode
2019-03-25T20:47:24.470Z Command[121] status: addNode, status: ADD_NODE_STATUS_LEARN_READY
2019-03-25T20:47:35.681Z Command[121] status: addNode, status: ADD_NODE_STATUS_NODE_FOUND
2019-03-25T20:47:35.855Z Command[121] status: addNode, status: ADD_NODE_STATUS_ADDING_SLAVE
2019-03-25T20:47:35.862Z Command[121] status: addNode, status: ADD_NODE_STATUS_PROTOCOL_DONE
2019-03-25T20:47:35.922Z Command[121] status: addNode, status: ADD_NODE_STATUS_DONE
2019-03-25T20:47:36.122Z Command[121] end: addNode
2019-03-25T20:47:41.011Z Command[122] start: addNodeAbort
2019-03-25T20:47:41.012Z Command[122] end: addNodeAbort
#9

And you already followed all directions given in the messages above? (the resetting the device part)

#10

for sure, the fibaro switch needed a reset of 3 seconds according to the manual… :frowning:

#11

Hear hear hear… found the solution… since these sensors where in my new badroom I learned that the new beton Cire solution blocked all wifi signals and Z-wave signals… the resetting was therefore impossible… Now it is working

#12

I am gradually saying goodbye to my Fibaro sensors and am replacing them with much simpler (and more effective) Hue motion sensors. They report temperature and luminescence far better and they have no connectivity issues which I seem to get frequently with that Fibaro sensor. Could be my setup but I get better results with Hue now and I don’t need to tamper alert which is the only noticeable advantage for Fibaro in my POV.