Homey Community Forum

Fibaro RGBW controllers moved to Homey give weird results

I’ve just removed 3 working RGBW controllers from my Home Centre 2 and added them to Homey.

I’m now getting somewhat erratic behaviour when trying to use the RGB lights.

  • I can turn them on and off fine from the app.
  • If i change the colours it’s a bit hit and miss if the colour change occurs or jumps back to the current one in the app UI.
  • If i turn on and off using the traditional wall toggle switch the colour seems to be reset to bright red.

It has been maybe 3-4 years since I set up the RGBW devices in HC2 so maybe I’ve forgotten some setting I should have done…

  • What is needed to make them turn on and off with a standard toggle wall switch and remember the last set RGBW colour?
  • Are there known problems still with the RGBW controllers from Fibaro - if so where are the issues listed to track?

I’m using App v2.8.0.383 (iOS) and Homey Pro v2.5.0

I’m not sure how or where I can see a log of events as there’s some ZWave error messages that flash up briefly when doing something things in the iOS app?

Set the following parameter of Fibaro module to 1:

  1. Response to BRIGHTNESS set to 0%
    Default setting: 1
    0 - illumination colour set to white (all channels controlled together)
    1 - last set colour is memorized
    Parameter size: 1[byte]

Thanks for the pointer. Sounds like it’s doable, at least.

However I can’t see in the mobile app > RGBW > settings > advanced settings where “response to brightness” is located?

Is ‘71’ something related to the device raw parameter ID?

Yes, in device setting under “Raw configuration parameters” you can set it manually: 71,1,1

okay, makes sense, done, and saved.

Tested on two of my RGBW devices - turned on the devices using Homey app, set a colour, turned them off.
When turning on using IN1 toggle wall switch the RGBW comes on as red still.

Ah, reading the RGBW manual - IN1 that the wall switch is connected to also controls the “Red”!

Thats the issue. Each color has its own input. In your case, you are switching only red channel.

From what I can decipher in the docs, it’s parameter 14 i need to change rather than (or as well as?) parameter 71?

I can’t grasp what value is expected for parm 14 though - other than it being 2 bytes in size :slight_smile:

I tried 71,1,1;14,2,7 but got nothing better out of it.

1 Like

Set it to 4x switch in parameters. and put outgoing wire from switch to fibaro input 1 then wire from input 1 to 2 to 3 to 4. so 1 switch turn on all 4 channels

Interesting suggestion - but this wasn’t necessary when the RGBW devices were controlled by the Home Centre 2 box. Some RGBW devices are in fiddly to access places such as ceiling cavities.