Homey Community Forum

Fibaro RGBW - just need a basic white LED to work

Hi All, I’m new to Homey and so far working great! I have a basic LED white strip light that came with my wardrobe, I have bought the Fibaro RGBW controller 2, I don’t have a wall switch, it’s just app controlled and I have just wired the white output on the RGBW module. It straight away worked well and dimmed really well but after an amount of time the LED light turns off without me interacting with it, but is still showing as on in Homey? I have read past posts on this but can’t figure out an answer… It seems that the fibaro is transitioning between colours or something? It’s a really basic use case that I have, is there a setting in the Homey app that can fix this? just need a simple white dimmer to always output white unless I turn it off…

Did you include the fibaro to a room/switch/flow or anything else then de light dtrip. Is the lightstrip itself turning itself off after X amount of time or maybe with a LUX or motion sensor?
Why went for a rgbw dimmer instead of a 12v dimmer?

No I just added it as device, no switch or flow… It’s for a friend of mine and he uses the homekit plugin, which works well. All he wants to do is use it through HomeKit for on / off and maybe some timed based automations. it does appear in HomeKit fine and is able to be controlled, but it does appear in homey and HomeKit with multiple colours, if you accidentally change a colour on the app the light strip goes off! but if you just toggle on / off or dim, it works fine… it seems to turn off after a few hours… can’t work it out. I used this device as a supplier told me it would work, but if there is a better option for my basic use of on / off and dimming please let me know. thanks

Well. If you change colour from white to green there is no power going to white anymore resulting in switching the white light off. The fibaro is still on with the green channel open so it appears to be on.

So if you’re not using the full spectrum of RGBW I don’t know why you should choose it.

What kind of light is it? A wardrobe light? Does it come with a transformer? I think a regular 12v dimmer would do the trick imo for a lot cheaper. It has to work with homekit right?

Edit: Searching for 12v dimmers for homekit results in a lot of people searching for those :wink: but you need to be able to dim or is on/off enough, then you could just put in a smart plug.

For all I care ditch the whole homekit :wink:

thanks, yes I understand that actively changing the colour would turn the white light off, just wish I could get it into homey without it presenting all the colour options… in the setting through homey I told it it’s a “white Light” only but I still get all the colour options… must just be how it is. it’s just a basic LED strip in a custom housing, with the 12v driver. Yes I did originally put in a smart plug for on/off, but then he asked if it could be dimmed as the light was too bright near his bedroom… that’s how I got here… if there was a simple ZigBee or Z wave device that definitely works with homey that dims that would be great… like I said the fibaro RGBW works perfectly, until it doesn’t…

Create Group with dimm only functionality and add Fibaro RGBW as an only device. Then setup the correct color on FIbaro to use only white channel. After that use only Group device that will be dimming RGBW and not changing other device settings.

Thanks Igy, I will definitely try this and report back. thanks

@Nick_J, I don’t have a Fibaro RGBW controller in use, but the manual says there are two settings. One setting for RGBW (default) and one setting for HSB and white mode.
I would try changing parameter 150 to 1 if not already done (long tap on the device → gearwheel → advanced settings → search for parameter 150).

Thanks Fantross, I will definitely try this. Yes I saw this in the fibaro manual, and it looks like it would solve my problem. it’s just a setting within a fibaro hub, but in Homey it looks like it can possibly be done only by raw parameter settings, which I’m not sure how to execute, a bit technical for me. I did originally search this but couldn’t find the correct parameter settings to input for what I want… And unfortunately when I go to advanced settings on the device in homey, I can’t see it as an option to change, can’t see parameter 150 unfortunately…

Raw configuration is not that difficult.

Parameter,Size,Value
Parameter = 150
Size in byte (1b) = 1
Value = 0 for RGBW / 1for HSB/White mode

Advanced Settings → Raw Configuration → 150,1,1 (without spaces)
That’s all.

Hi Everyone, sorry for the late reply, I wasn’t able to go back until last week but I have managed to get this working OK now. @fantross I did input the raw config you sent me, I’m not sure what effect it had but hopefully it helped as it’s definitely working better. I did notice though it still seemed to be switching through the RGBW colours after an amount of time, so to get around it I just looped a wire from white through to all of the 4 outputs, so if it does color cycle, the LED will still stay on… My friend told me so far so good and that was a week ago so I think this is solved…