Homey Community Forum

Fibaro sensor + switch associatie

Momenteel heb ik (o.a.) een multisensor + dubbele switch van fibaro.
Allebei z-wavePlus.

Ik heb een flow waarbij de lamp aangaat als de sensor beweging detecteerd. Dit werkt eigenlijk best goed, alleen soms kiest de node ervoor om een ‘omweg’ te maken lang een paar andere nodes. Het gevolg hiervan is dat het +/- 1,5 sec. duurt voordat de lamp aangaat. Opzich wel logisch, daar het best op afstand is van de homey.
Eigenlijk geen groot probleem, maar mooier is wenselijk.

Nu dacht ik dit op te lossen door een associatie. De sensor stuurt direct de schakelaar en naar de controller. (voor alarm).
De flow voor lamp aan/uit wordt dan wel uitgezet in homey.

Ik heb het nodeID van de schakelaar (8.2) toegevoegd aan groep 2 van de sensor.
Echter komt het bericht niet goed aan bij de switch. Op de homey komt het nog wel binnen.

Alle opties onder 18, of commando’s wel/niet beveiligd worden verstuurd heb ik geprobeerd.

Het valt me wel op dat de Dubbele switch 2 op secure staat en de multisensor heeft een kruisje achter secure. Wellicht dat het daar inzit, maar ik zou niet weten hoe ik die sensor op secure kan krijgen. Volgens fibaro zou de sensor wel een secure verbinding ondersteunen.

Hopelijk heeft iemand dit ooit eens meegemaakt en kan mij opweg helpen :slight_smile:

Ik ben weer even aan het testen gegaan.

Als ik in groep 5 een associatie maak werkt deze wel. De rest van de settings staan op default. helemaal onderaan deze pagina: https://manuals.fibaro.com/motion-sensor/ zie je dan ook bij setting 29 dat hij een backward compatible alarm verstuurd naar groep 5.

Als de sensor nu een alarm geeft wordt er daadwerkelijk wat verstuurd (of ontvangen).
Voeg ik een id toe aan groep 3 en verwijder hem weer uit 5 dan werkt het niet. (wat weer in lijn is met de motion)

Zal het dan toch de secure verbinding zijn? In homey geeft die een kruisje. Bij setting 18 ( 18. Associations in Z-Wave network Security Mode) waarbij je per groep kan bepalen of die secure moet zijn of niet heb ik alle opties al geprobeerd.

Om lekker in mijn eigen wereld te blijven en mezelf te antwoorden :slightly_smiling_face:
en mocht iemand via een search hier terecht komen :slight_smile:

Ik heb de fibaro app gecloned. De driver settings voor de double switch omgezet zodat deze unsecure wordt geinclude en naast de officiele app geinstalleerd . De schakelaar verwijderd via de officiele fibaro app en opnieuw geinclude via de gekloonde app waarmee hij unsecure toegevoegd werd aan homey. Daarna werkt de associatie zoals je verwacht.