Homey Community Forum

Fibaro smart implant impulse; homey seems to keep it pressed when toggled

What I’m trying to do
I’ve got a ventilation aggregate with an impulse input which will force the aggregate into “max” mode for 30 minutes. I’ve connected a Fibaro Smart Implant to the input like in the impulse example from the manual except for the input switch. I’ve created flows to trigger the output 1 when co2 reaches a certain level, or humidity reaches a certain level.

What’s working
The Fibaro Smart implant is connected to homey. The aggregate is switched into “max” mode when output 1 is triggered.

The problem
When I push the output 1 in the homey device it seems to stay in “on” mode, and therefor the impulse is continually triggered instead of being triggered once. Can I configure the Fibaro Smart Implant in homey to flip back to off mode so it acts like an impulse switch?

I realize it’s possible to create flows to turn the output 1 off again, but before following down that path I’d like to now if what described above is possible.

Don’t think this device has inching mode (pulse mode) . In the same flow where the swiching ON is done, you can make second card for switching OFF with a delay of 1 second.

1 Like

Ah, clever thinking, didn’t cross my mind. Thank you.

1 Like

The Smart Implant has of course a pulse mode.
You have to edit the parameter 156 for output 1 and/or parameter 157 for output 2.
You have to do it with “Raw configuration” in the advanced settings of the SI. But it is only possible if the SI is included insecure. If the SI is included secure, you have to include it insecure first. This is possible when you choose the “Fibaro Walli Switch” as device instead of the SI while adding it again.

Example Raw configuration
Advanced setting → Raw configuration parameters → 156,2,10 → save
156 = output 1
2 = Size of the parameter (2 byte)
10 = 1 second

Example flow
When…
– This flow is started
Then…
– Output 1 on

Check
You can check it in Developer → Devices → Capabilities (of the SI) → onoff.output1 → true/false

2 Likes