Homey Community Forum

Fibaro/Z-wave probleem (unsecure include)

Ik ga dit ook eens proberen, ik heb maar 2 dimmers van Fibaro, de Switches zijn verder allemaal al insecure.
Is dit een Fibaro probleem, ik heb namelijk 2
Aeotec Z-wave Plus Range Extender die ook secure zijn. Geeft dit dan dezelfde problemen?

Waarschijnlijk niet. Mijn vermoeden is dat de fibaro modules de data stroom niet aan kunnen. Bij unsecure word er veel minder data verzonden.

Goeie tip, ga ik onthouden!

Blijkbaar is er een makkelijkere manier om Fibaro devices unsecure te includen middels de originele Fibaro app, namelijk het includen starten als het toevoegen van een Walli Switch. Zelf nog niet geprobeerd overigens, maar de tip komt van gebruiker @Osorkon : Z-Wave Geräte unsecure inkludieren

Ik heb net even gekeken in de broncode, en inderdaad.
De Walli dimmer zou ook moeten werken.

Edit; zat nog even verder de snuffelen maar het lijkt erop dat alle “Walli” apparaten de unsecure regel hebben.
Ook de smart implant bevat de unsecure regel

1 Like

De engelse beschrijving staat hier: Add Z-Wave device non-secure?

Dit topic volgde ik al een tijdje, maar ik zag nogal op tegen het opnieuw koppelen van al mijn devices. Ik heb 30 Fibaro dimmers/schakelaars en een week geleden toch maar de stap genomen om alles unsecure te maken. Uiteindelijk ben ik 4 uur bezig geweest om alles om te zetten van secure naar unsecure inclusief het fixen van alle flows. Het kostte dus even wat tijd, maar het was het waard. Wat een verschil! Echt onvoorstelbaar. Voorheen duurde het uitschakelen van 7 lampen tussen de 10 en 45 seconden en dan waren er uiteindelijk tussen de 5 en 7 lampen uit. Exact dezelfde flow met dezelfde actie schakelt nu binnen een halve seconde alle 7 lampen uit. Altijd. Dit is hoe het moet werken. Voorheen was het eigenlijk sneller om de lampen gewoon met de hand uit te schakelen, maar nu heeft het echt meerwaarde.

In de oude, secure mode, heb ik ook best wat tijd besteed aan workarounds. Ik heb geëxperimenteerd met vertragingen tussen de kaartjes, uitschakelen per zone, de group app etc. Uiteindelijk werkte niets echt goed. Nu, in unsecure mode, maakt het totaal niet uit hoe ik de acties uitvoer. Het werkt gewoon altijd en snel. Eigenlijk zou Athom deze devices gewoon standaard unsecure moeten includen. Dat zou een hoop mensen blij maken denk ik.

Ik kan ook bevestigen dat het toevoegen van een schakelaar waarbij je de “Walli” selecteert de schakelaar ook unsecure toevoegt. Dus uiteindelijk hoef je inderdaad niet eens zelf een andere app te installeren. Je kunt dit gewoon doen met de app uit de store.

8 Likes

nadat ik een vraag in een ander topic gesteld had ivm mijn fibaro roller shutters
kwam ik op dit draadje.
Heb wat verder zitten zoeken maar je kan dus alleen usecure kiezen door de app te wijzigen.
Maar ik wil al mijn devices op unsecure hebben zo had ik het met domoticz en was nooit een probleem.
Ben overigens bij domoticz weggegaan ivm linux problemen op de Pi.

Die heb ik inmiddels op een andere manier opgelost (draaide met berry-boot en een hd).
Heb met de homey tegenslag na tegenslag gefix maar dit gaat me toch iets te ver.
Heb van diverse merken zwave draaien, aeotec, fibaro, qubino en nog een paar, als ik al die apps moet gaan aanpassen daar word ik niet vrolijk van.

Gezien mijn homey nog geen maand in gebruik is zit ik er hard over te denken terug te gaan naar domoticz.

Voor Fibaro hoef je geen andere app te installeren om je apparaat unsecure te maken. Het werkt als volgt:

  • Exclude het apparaat van Z-wave
  • Voeg een nieuw Fibaro apparaat toe, maar kies altijd een Walli apparaat, ongeacht welk apparaat je wilt toevoegen.
  • Omdat Walli standaard unsecure wordt toegevoegd, initieert Homey de pairing unsecure. Het plaatje dat je in de app ziet klopt dan alleen niet.
  • Start pairing op het apparaat dat je wilt toevoegen (waarschijnlijk 3x klikken)
  • Homey paired unsecure met het apparaat en komt er dan achter dat het een ander apparaat is.
  • Homey herkent het juiste type apparaat, maar omdat de pairing unsecure is gestart, wordt het apparaat unsecure toegevoegd.
  • Klaar.

Voor de andere Z-wave apparaten zou ik alleen moeite doen als er ook echt een probleem is. Sommige andere Z-wave apparaten die ik heb, werken prima in secure mode. Ik betwijfel ook of de problemen met Fibaros in secure mode echt door Homey komen. Ik sprak laatst iemand met Home Assistant en Fibaro en die had precies hetzelfde probleem in secure mode. Dus het zou net zo goed aan Fibaro kunnen liggen.

2 Likes

Thnx.
Wilde al bijna de pi weer plaatsen.
Wat ik al melde bij domoticz default unsecure en secure als je dat wilt.

Zijn die icons en type van het apparaat te wijzigen?
De opties daarvan zijn nogal beperkt.
Bij domoticz kon je eigen iconen maken met on/off icons dus over de namen nog maar niet te spreken.
Ander topic eigenlijk ook.

Dat is ook exact mijn vermoeden. Het lijkt erop dat de fibaro modules de data stroom niet aankunnen.

Dat is bij Homey (nog?) niet mogelijk

Nee helaas. Dan moet je de code van de app aanpassen

2 Likes

Als ik developer kijk en dan zwave zie ik vaak dat de rolluiken Unreachable zijn.
Ook zo voor de Universal Binary sensor (allemaal fibaro)
Ook de aeotec multisensor 6 staat dat hier naast online :upside_down_face:

Dat heb ik ook bij veel z-wave. Als je dan ‘test’ doet, dan doet ie het gewoon weer en gaat de melding weg. Het zit niet in de weg voor een goede werking.

maar vreemde is dat het alleen fibaro apparaten betreft.
maar het werkt inderdaad wel, al is het niet helemaal 100%

Ik heb het ook bij m’n coolcam apparaten. Wat het is, geen idee… range kan het iig niet zijn bij mij.

Heb domoticz op mijn Py vers geinstalleerd nu.
Maar als je kijkt voor includen heb je meer opties.
image

  • Exclude het apparaat van Z-wave
  • Voeg een nieuw Fibaro apparaat toe, maar kies altijd een Walli apparaat, ongeacht welk apparaat je wilt toevoegen.
  • Omdat Walli standaard unsecure wordt toegevoegd, initieert Homey de pairing unsecure. Het plaatje dat je in de app ziet klopt dan alleen niet.
  • Start pairing op het apparaat dat je wilt toevoegen (waarschijnlijk 3x klikken)
  • Homey paired unsecure met het apparaat en komt er dan achter dat het een ander apparaat is.
  • Homey herkent het juiste type apparaat, maar omdat de pairing unsecure is gestart, wordt het apparaat unsecure toegevoegd.
  • Klaar.

Gisteren dit toegepast op een Fibaro Dimmer 2 verbonden met 2 inputs (tuimelschakelaars) die soms niet altijd even goed reageerde op de S2. Sinds ik deze unsecured heb kunnen pairen reageert hij telkens direct en werken alle flows die aan de S2 gekoppeld zijn perfect!
Wat is het grote “nadeel” van iets unsecured toe te voegen?

Niet veel. In theorie kan nu het signaal worden ondervangen door derden.

Wat ik heb begrepen is dat het met name voor keypads en doorlocks interessant is. Om nu een lichtschakelaar te hacken om vervolgens het licht aan en uit te kunnen doen is irritant, maar niet meer dan dat. Daarnaast moet je dan ook nog in het bereik van z-wave zitten, want niet bijster goed is. Het risico is wat mij betreft te overzien. Wellicht dat er een potentie is om door te hoppen en zo via een lamp verder je netwerk in te komen, maar goed… dan nog moet je in bereik zijn en duurt dat vrij lang.

Ik heb een paar weken terug alle fibaro devices unsecure toegevoegd.
Eerlijk gezegd kan ik niet echt verschil merken.
Zie nog steeds devices die unreachable zijn bij test zijn ze er echter weer.
Maar ook status van b.v. een rolluik klopt van geen meter.

Ik weet dat dit wel goed kan werken want dat deed het bij domoticz wel.