Homey Community Forum

Fibaro/Z-wave probleem (unsecure include)

Hebben mensen nog reacties ontvangen van Athom over dit probleem? Ik zit helaas in hetzelfde schuitje

Ik heb er contact over opgenomen met Athom en die geven aan dat ze het niet veel horen en het dus een uniek probleem is. Dat lijkt hier toch anders.
Ik wacht nu weer even op een moment dat het weer misgaat om een diagnostic report op te sturen (ik ga er even vanuit dat een diagnostic report iets zegt over een periode die geweest is).

Ik heb ook contact gehad. Ze gingen het “weer” doorspelen naar development.
Het probleem lijkt inderdaad niet uniek.
Frustratie niveau is inmiddels erg hoog bij mij.

Ik heb zelf het idee dat het een timing dingetje is bij het uitsturen naar de dimmers.
Ik zou ook graag willen weten welke firmware ik op de dimmers heb. Ik kan daar niet echt achter komen.

Hi guys,

Ik ben zelf (nog) geen Homey gebruiker, maar ik gebruik Domoticz. De reden dat ik hier aan het rondkijken ben is dat ik met enige regelmaat te maken heb met Fibaro modules die het niet doen in een ‘scene’ (de Domoticz-variant van een flow). Dat was ik behoorlijk zat, en ik ben eigenlijk op zoek naar een alternatief.
Nu ik dit topic lees denk ik eerder dat het probleem bij de Fibaro modules ligt dan bij de controller…
In ieder geval lijkt een overstap naar Homey geen oplossing te bieden voor dit probleem.
Jullie hebben verder niet zoveel aan deze bespiegelingen, maar misschien biedt het feit dat dit verschijnsel zich ook bij een andere controller dan Homey voordoet een aanknopingspuntje.
Succes ermee!

Thanx voor je input.

Ik zat daar ook al aan te denken dat het toch aan de fibaro dimmer modules ligt aangezien ik verder geen enkel z-wave probleem heb.
Zoals al eerder gezegd heb ik ook geen problemen de fibaro shutter modules maar alleen met de dimmers.
Wat ik graag nog zou willen proberen is een firmware update van de dimmers maar ik beschik helaas niet over een fibaro home center.
Ik zit er over te denken om ze op te sturen naar robbshop, die heeft een update service.

Weet iemand of het mogelijk is om via homey de firmware versie te achterhalen?
Ik kan wel de firmware ID vinden (274) maar weet iemand welke versie dit is?

Damens en heren, ik denk na bijna 7 maanden ergernis de oplossing te hebben gevonden!! :partying_face:

Ik zal bij het begin beginnen, ik kwam op het idee nadat ik bij toeval op een topic stuite (weet niet meer welke) waarbij iemand vertelde dat hij al zijn z-wave devices unsecure had ge-paired.
Hij beweerde dat daardoor zijn hele z-wave netwerk veel sneller reageerde omdat er veel minder data verstuurd hoeft te worden.

Ik dacht gelijk, dat moet ik ook proberen. Echter de fibaro dimmer 2 modules heeft geen instelling om group 1 unsecure te pairen met Homey.
Group 1 kan je allen unsecure instellen als dit vanuit de hub geregeld word. Homey in dit geval

Dit was best een uitdaging aangezien de Fibaro Homey app dit niet ondersteund.

Maar naar lang zoeken heb ik de oplossing gevonden.
Je moet de volgende regel toevoegen aan de broncode van de dimmer 2 driver
includeSecure": false,

Hoe dit moet kan je allemaal in dit draadje lezen

Ik heb hiervoor de alpha versie van de fibaro app gebruikt van Github [2.2.8]

Toen dat allemaal gelukt is en de app handmatig is ge-installeert, heb ik al mijn dimmers verwijdert en dus weer “unsecure” toegevoegd aan Homey.

En tadaaaaa… alles werkt. :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face:
En hoe…
Alle dimmers gaan nu tegelijk aan en uit en ook het dimmen gaat nu perfect met bijna geen vertraging meer.

Uiteindelijk was het wel een avondje werk want alle flows waar mijn dimmers inzitten moesten worden hersteld.

Nu een weekje laten draaien en hopen dat het blijft werken :crossed_fingers:t2:

4 Likes

Ik ben erg benieuwd hoe het nu gaat? Draad het nog steeds stabiel?

En of het ook werkt voor Double Switch 2, want ik heb de laatste tijd vooral een issue met 1 van de 2 schakelaars op een double switch 2… de dimmers gaan eigenlijk heel goed de laatste tijd (afkloppen)

Het draait super stabiel! Kan nu echt weer blij zijn met Homey :smiley:
Het drukken op de knop en het aangaan van de lampen zitten maar een paar milliseconden tussen. Zo snel heeft het bij mij nog NOOIT gewerkt.

Ik heb inmiddels de “standaard” app weer ge-installeert uit de app store zodat ik weer automatisch updates ontvang. De dimmers blijven dan gewoon unsecure
Ik kijk het nog een paar dagen aan en als het zo blijft zoals het nu is zal ik dit ook even naar Athom communiceren.

Grote kans van.
Er is op monet een vork op github met een fibaro app verrsie waarbij je een aantal Fibaro modeles unsecure kan include.
Oa de FGS-213 staat daar tussen. Helaas mijn Dimmers 2 niet waardoor ik de app zelf heb aan moeten passen.

Aangezien de devolpers van de Fibaro app experimenteren met het unsecure toevoegen van modules, vermoed ik dat er meer problemen zijn.

2 Likes

Ik kijk het nog een paar dagen aan en als het zo blijft zoals het nu is zal ik dit ook even naar Athom communiceren.

Hoor graag terug van je. Het unsecure toevoegen van dimmer modules is een beetje boven mijn kunnen. Zou super zijn als dit door Athom wordt aangepast als een mogelijkheid.

Ben blij te horen dat er eindelijk een oplossing is die blijft werken. Wel erg eigenlijk dat dit niet door Athom/Fibaro opgelost kon worden. (niet verkeerd bedoeld Tasz :slight_smile:)
Ben superblij dat je het gevonden hebt, zal dit weekend ook jouw manier volgen.
Dus alle toestellen moeten terug verwijderd worden uit zwave?
Het lukt ook niet met de app of Homey te herstarten? (na de aanpassingen in de broncode)

Nogmaals bedankt :wink:

Hey mensen,

Ik heb sinds een tijdje ook problemen met mijn Fibaro’s en Homey. Maar ietsje anders dan jullie zeggen. Namelijk dit, als we bijv een lamp hebben uitgezet met de muurswitch, dan geeft de homey app soms gewoon nog aan dat ie aanstaat, terwijl ie dus uit staat, niet echt handig dus :-S

Lijkt dit op jullie probleem? Ik heb 't vermoeden dat dit ook opgelost wordt als jullie probleem ook opgelost is :stuck_out_tongue:

Dat is hetzelfde probleem als ik heb inderdaad. Aanblijven terwijl Homey zegt dat ie uit is en andersom.

Je hebt inderdaad helaas wel wat kennis nodig.
Nu moet er uitgezocht worden waarom een beveiligde verbinding niet werkt met de dimmers. Dat het unsecure toevoegen het werkbaar maakt is natuurlijk nog niet DE oplossing.
Maar hopelijk kan Athom hier verder mee en komt er dan een definitieve oplossing voorm iedereen

Ik had dit probleem niet. Opzich werd de status van de dimmers altijd wel goed doorgeven.
Wat natuurlijk niets zegt dat het unsecure include voor jou ook de oplossing kan zijn.
Ik zou zeggen, ga het proberen :wink:

Ze moeten inderdaad eerst verwijderd worden om ze vervolgens weer opnieuw te verbinden.
Herstarten heeft geen zin.

1 Like

Top @Tasz,

ik heb gisteren een alternatieve fork gemaakt feature/insecure gebaseerd op de alpha branch, aangezien de crashgh/com.fibaro commit wel erg veel wijzigingen mbt unsecure maakt, waardoor er een alternatieve fibaro app ontstaat en de apparaten die daarmee gepaired worden nooit meer met de originele app kunnen worden aangestuurd.

Het enige wat ik gedaan heb tov de originele code is in de drivers die ik nodig had de regel

"includeSecure": false,

toegevoegd, in de zwave properties (na productId, maar dat is eigenlijk niet belangrijk). Bijv in de file “drivers/FGD-212/driver.compose.json

Daarna heb ik “homey app install” gedraaid (waarna de app.json opnieuw wordt opgebouwd), en vervolgens het apparaat verwijderd, en opnieuw geinclude.
Je merkt dan inderdaad dat de apparaten een stuk sneller reageren. Dit merk je helemaal als je bijv. via een kaku afstandbediening via Homey je zwave lampen aan/uit zet, of via een flow alle lampen uit laat zetten. Ik vermoed dat dit ook de stabiliteit ten goede komt, en dus de status (aan/uit zijn) beter gesynced zal zijn.

Ik vermoed trouwens eigenlijk dat je maar 1 apparaat uit de Fibaro reeks hoeft te voorzien met de includeSecure:false eigenschap. Als je vervolgens andere type apparaten wilt includen, kies je gewoon voor de door jouw aangepaste module, aangezien het pairen dan unsecure geïnitieerd wordt en vervolgens pas geresolved wordt welk soort module het uberhaupt is, waarna de bijpassende driver wordt gezocht (echter is dan het includen al insecure gebeurd).

In ieder geval bedankt voor het opmerkingen en uitproberen en bij deze de bevestiging dat het bij mij ook een verbetering oplevert. Hopelijk komt Athom hiermee inderdaad verder, maar ik houdt het voorlopig bij insecure includen.

1 Like

Dit is afhankelijk van het type schakelaar, er zijn enkele (oudere?) types die dit probleem hebben, heb voor FGS-221 en FGS-212 een melding gemaakt bij Athom, als meer meldingen gedaan worden, zal het eerder opgelost worden, hoop ik.

Hey Jan,

Ja dat is precies wat wij ook hebben ja :-S

En pas sinds een tijdje. Geen idee welke schakelaars we hebben, zou ik moeten kijken of ik 't doosje nog heb
:yum:

grtz Boris

@Tasz Draait alles nog ok bij jou?
Als ik kijk op https://github.com/crashgh/com.fibaro/tree/92641bf59f55ac48bf6334bba461f90c050b3fa4 dan zie ik de Dimmer2 wel er tussen staan?
(of dit is al een update?)

dus m.a.w. gewoon deze github downloaden en installen?
devices verwijderen en opnieuw pairen en klaar is kees?

Nogmaals bedankt :slight_smile:
Hopelijk gaat het hier ook heel wat sneller dan dat het nu is, want voor zoveel geld mag het toch wel echt in orde zijn vind ik.

Ik kom van Domoticz op een Raspberry Pi en had daar alles in php geschreven in eigen scripts en werkte perfect . Ik had zin in een nieuwe uitdaging en ben naar Homey over gegaan, maar dit was tot nog toe een serieuze tegenvaller :frowning: (95% door het probleem dat jullie ook hebben/hadden)

De commit waar je naar wijst is de fork van @Tasz, daar zit de unsecure include patch in, maar mijn ervaring was dat de homey tools bij installatie de aanpassingen ongedaan maken omdat de bron bestanden niet aangepast zijn (enkel de build output).
Dus mocht het bij jou ook niet werken, bekijk dan mijn repo waarin ik het iets anders geïmplementeerd heb https://github.com/lvanderree/com.fibaro/tree/feature/insecure

Bij mij werkt het nu ook een stuk sneller en stabieler, zonder encryptie.

2 Likes

Hey, ok bedankt alvast.

Dus moet je dan alle zwave toestellen verwijderen? Of Reset ZWave netwerk?
Of enkel het zwave toestel die je “geupdate” hebt?

Bedankt