Homey Community Forum

Finally solved ripple control side effects, no more sudden brightness on fibaro dimmer2

Maybe others can benefit from this as well. For 3 months I have been struggling with the side effects of ripple control signals (in Dutch “toonfrequent”), causing the LEDS on my Fibaro 2 dimmers to brighten at fixed times each night (about 5x each night). It drove me crazy. I finally found out this weekend that there is a setting (parameter 38) that is meant to prevent flickering of LEDs, but causes sudden brightness in 2-wire setups in combination with ripple control.
Setting this parameter to 0 solved it. (raw configuration: “38,2,0;”).

5 Likes

I just did the raw setting.
I realy hope this will help.
I do have the same frustration and was allready figuring out how to get a blue wire tot the switch.
I will inform you about the results

I hope it works out for you as well! It drove me crazy, I was already planning of replacing dimmers with switches and gave it some final attention this weekend.
For two of the dimmers I could get a blue wire to the dimmer, for the other 6 that is nearly impossible for me. After I found out about this setting I tried it on half of my dimmers and it worked. I can also see that in the energy consumption of the dimmers. The ones that had this raw setting are now neat flatlines, the other ones showed peaks at the ripple control times. All fixed now (fingers crossed…)

It’s now on for one hour without flashing.
It looks like it’s working
If it’s true I’m very happy :ok_hand:t2::sunglasses: :grinning:

Edit: it is running now for one night, I’m convinced now it’s working.
I’m really happy. Thanks for the advice

Glad I could help!

This was also mentioned before here, with some technical information about the parameter: Fibaro Dimmer 2 > parameter 38 (firmware version 3.5)

In my case, I have 2x Fibaro Dimmer 2 and I used ‘38,2,125’ to get it to work properly. If i’m correct, it depends on the specific build of your Fibaro Dimmer 2. I have this for i think a year now and works like a charm. I also used the Bypass 2 of Fibaro for the ‘normal’ flickering with dimmers when power consumption is below 25 watt.

Why the 125 value?
For ripple signal disturbance the Fibaro manual mentions to set it to 0, so no anti-flickering.

Hm, good question @Jo_San . To be honest, I don’t know why I did it back then… but as we speak I have changed it to ‘38,2,0’ because that makes a lot more sense. I do know that I updated the Fibaro Dimmer 2 firmware by Robbshop, I don’t know if that changed the behavior. But for all others who are reading this, it makes more sense to use ‘38,2,0’ so please use that. And you can use the link 2 reaction earlier for some technical info about the parameter.

Oh I did not mean for you to correct it, I was just curious about where the 125 value came from.
As with many things with Homey/Fibaro etc: if it works, it works (and then don’t touch it :grinning:)

In the beginning I was happy about entering the raw setting.
But the LEDs still flickering about once an hour. Not going up and down anymore, but just flickering for half a minute and then stopping flickering for about another hour
Any ideas about that?
I did just try now the 125 value

I do set brightness to 5 %
It is less anoing then going up and down in brightness

Do you use a Bypass ? when to total load is below 25Watt, (could also be when your brightness is low) you need to use some kind of bypass like the Fibaro Bypass. This is a behaviour which you can experience at all dimmers in combination with a low load (25watt and below) and LED lights. If you experience this flickering always when you dimm the light to a lower level, it’s very likely this is the problem. If you experience your problem only during the night at specific times, your configuration of the 38 parameter is not correct. Try the ‘38,2,0’ setting instead of ‘38,2,125’.

Hope you will get it to work :slight_smile:

Yes i do use the bypass
I did try both settings 0 and 125 no difference

De brightness going up and down is gone.
It now only flickering now and then

@Canedje Hm, sounds like you fixed the TF (ToonFrequent) issue. :slight_smile: The occasionally flickering is something i’m not sure off what it is if you have a bypass. I do have an IKEA lamp which I made dimmable which has random flickering. But that’s because it doesn’t have a bypass… I can’t place a bypass in a standing lamp.
You could try change the LED light bulbs with other light bulbs to test if they are the problem or something else. Another thing is that you can calibrate your dimmer again, maybe this can fix your issue ? I know there are quite some advanced settings for de Fibaro Dimmer 2, maybe there’s your problem, you could also try to set the settings to there default values to test if there’s your issue.

I don’t know what will help, but try some things to find out where your problem is (the lights, dimmer settings, electrical issue etc.)