Homey Community Forum

Flow Airco/Power usage -Sensibo+homewizard

Hello,

I installed a Sensibo unit to control the airco. Now i only want the airco to work when temperature is above 20° and the Homey P1 meter tels me i have +1000kwh extra energy.

I started with this;


(Target temperature is measurement from sensibo)

(Temperature logic is measurement from sensibo unit)
(Current usage from P1 meter)

But now the temperature is above 20° and the power is -1700kwh but nothing happens. What is wrong with my flow?

Kind regards!
Yov

I don’t have any of those devices, so I don’t know what is the output value “Current usage” from the P1 meter. But I guess this should be the mistake.
To check this flow you can push the “Test” button to see which condition in the “And…” part doesn’t fulfill the requirement at this moment. It will be marked with a red exclamation mark.:exclamation:

Hello and thx, why do you think this is the isue?

With this a pictute of the “current output” selected from the “and” logic.

At the moment the output is lower then it needs to be in order for the flow to work. Il adjust it to within limits and test everything.

Thx!

Edit, i did the test function, did not get any errore (i get a error when the current output does not match) But the Device is not activating, Al the AND variables are reached.

Kind regards,

As I said, I don’t have any of those devices and it was an assumption.
To understand it a little bit, what does „Current usage: -609“ exactly mean.

1 Like

The current usage is the power consumption minus the power production in Watts. Your trigger for the flow is when the target temperature has changed, that is a setting of your sensibo. You have to replace with a trigger when temperature (don’t know from which sensor you are using temperature in the AND part).

1 Like

You have to use the card “The temperature changed” and not “The target temperature changed” in the “When…” section.

1 Like

The -609 means i am putting -609kw energy back on the net (solar pannels)

thx to @tlangelaar and @fantross i think this did it, Everything is working, only downpoint now is that when the temperature drops the flow is starting again and the Sensibo sends the command again, i solved this by adding a “disable flow” card and activate the same flow when i turn down the airco. I dont know if there is a “cleaner” solution for this.

Yes, that’s right.
Instead of disable/able the flow you can use variables. But therefore you need additional flows.
If you are interested in this solution please let me know and I will post a sample.

I am yes! Thank you in advance! :wink:

Depending on the temperature, the variable AirconOn ist set to Yes or No.
If the variable AirconOn changes from No to Yes the flow AirconOnOff is triggered once. But the aircon will only be switched on, if the Current usage (in my case “Leistung”) is less than -1000 at this moment.
If the variable AirconOn changes from Yes to No the flow AirconOnOff will be also triggered, but the aircon will be turned off because of the else option in the Then… section, independent of Current usage.

If you want to switch the aircon on while the temperature is already above 20 °C (variable AirconOn = Yes) and the power changes from > -1000 to < -1000, then you have to add some more flows.