Homey Community Forum

Flow exectuted too many times

I have a set of hardwired PIR with Fibaro Smart implants fitted to make then “smart”. Why ? I never found battery powered smart PIR where the battery had a decent life time.

The Smart implants trip a flow to put a light on for 1 min if it is after sunset and before sunrise, i.e. darkness, and a light is not already on.

I get a message ont he home screen that says “Hallway PIR at Night Time has been disabled because the flow exectued too many times.”

Believe this happens if the flow triggers more that 10 time per sec, or 120 times per min. The light on the PIR does not flash that quick, and the Smart implants only read opening of the normally closed PIR contact.

Not sure how i stop this happening. Any ideas ?

Andrew

Looks like a Homey issue.
I had this with several flows (wifi presence). i havent found the cause.

just re-enabled the flows and it never happened again

Which PIR sensor do you use?
Which blind time is set?

One possibility would be to disable the flow for a certain time after activation. After this time the flow must be reactivated.

Please post the flow.

Using Honeywell Intellisense PIR IS312.
Not sure the blind time can be set, but the indicator LED comes on for about a secong before it goes off again, so flow should only trigger once in a second maxuium.

The Aqara motion sensor has a pretty decent battery life, mine have been running for about a year now, with the “5 second hack”, and still working great in a relatively busy area of my home.

I guess that the PIR triggers several times or that the input no. 1 of the Smart Implant remains open and thus triggers the flow again and again. But this is only a guess, I myself do not have a Smart Implant in use.
You can see the change of state in Developer, maybe have a look on it.

Which actions can you select for the Smart Implant (section “If…”)?

Smart implant has “Opened” “Closed” and “Switched” options.
There appears to be no other settings you can play with.
Selected “Opened” as the trigger as “closed” would be a slow reaction and “Switched” would action flow on both the open and close of the switch.

Have removed the “Sunset” and “Sunrise” check now to see if this helps and have a scond flow to enable these flows and others after sunset and disable before sunrise so they are not working during the day .

“Sunset” and “Sunrise” triggers only one time. So I guess this should not solve this problem.

How about this:
If…

  • “Switched”

And…

  • Logik “On ist ´yes´” (or something similar what it is possible)

I had the same problem with my Smarti Implant and also a Fibaro UBS, both connected to different devices. It seems that they reads "“false inputs”, on mines, sometime, but not always, I get multiple actions with the consequence of forcing the flow to be disabled.

I had to make a Virtual Sensor (using VD app) and pilot its state with and independent flow from the Smart Implant. Then use the Virtual Sensor state in your flow.

1 Like

With a variable this should also be possible.

It might also be a debounce problem. Sometimes potential free contacts tend to “vibrate” during closing especially with low load which fibaro smart sensor presents. Don’t have the answer how to test or fix this.