Homey Community Forum

For all the Ikea Tradfri Gateway users with the unknown_error problem

There are some people that are having problems with the Ikea Tradfri Gateway app and hub that suddenly, out of nothing, the lights can’t be controlled anymore and the message is ‘unknown_error’ when changing a light.

The only solution seems to be rebooting the app or the Homey itself.

I think i may have found a cause for this problem, it looks like something like a sleep or so.

I made the following flow and now the lights are working for 1 week straight, where normally i have to reboot the app multiple times per day.

If: every 15 minutes
Then: toggle (a random) ikea bulb on or off

This does turn off and on the bulb (in my case in the kitchen, every 15 minutes and seems to keep the connection alive(?)… idk, but it helps for me!

2 Likes

I was having this problem for a while now. What I just don’t understand is why some haven some don’t have this problem. I now have quit using it and added all bulbs to my hue bridge.

On a side note, hopefully the app gets updated some time to also support the blinds.

I suspect Homey’s less than stellar (wireless) networking to (at least partially) cause this issue.

Same issue here. Running Homey v3.1.1 and Gateway v.0.1.0, I get an ‘unknown_error’ if no lights are adjusted for a longer period.

All my ikea devices (30+) works with the ikea gateway app by using this procedure:

I reboot homey every night at 03.00 (memory leak🙄) after 15 mins i made a flow reboot the ikea gateway app.

remember if power have been cut to the physical ikea gateway(IG) do a ptp on IG, remount power source for IG, wait 15 min: reboot gateway app on homey

Same issue here and it’s getting worse now. Even rebooting the app must be done for several times to get it working again. Using the Ikea app it selves works always so it must be some connection problem between Homey and the Tradfri Gateway.

I’m planning to move the lights to Homey. I have a part of the lights already working in Homey but in the past it gives issues when starting 6 lights at the same time. So i’m a littlebit worried to do so