Homey Community Forum

Global Caché

ok thanks, it looks like the beacon msg is a bit different on the gc-100… I’ve updated the app so please have a look when you have time.

Thanks!

Installed the new version and the IP2IR worked great! haven’t had time to test the IP2CC and IP2SL. Let me know if you want me to test something more.

Yahooo!!! Finally. I have a whole bunch of iTaches for use with Simple Control, now I can integrate them with Homey as well!!

Now, I just tested the two IP2CC’s I have for controlling curtains (in parallel with dumb momentary wall switches).

One thing that wasn’t obvious was that the delay setting is used for “lining up” commands in sequence

I wonder if, in general, the THEN part in Homey Flows is executed in the graphical top to down sequence in case the same device is controlled, or is it sent simultaneously (my curtains going crazy before I discovered the delay setting :slight_smile: )

And, if there are several devices, a subflow is executed for each in the top-down sequence?

These to me are crucial questions. For example, you have to wait for the TV to turn on (delay an empirical X seconds) and only THEN send Change input command. But you don’t have to wait for the TV to finish all this, you can start sending commands to your receiver in parallel, at the same time to save the overall scene execution time.

So, the question is, how does the GlobalCache app handle this?

BTW, the Simple Control subscription (arrrrgh!) whose very existence you’re starting to threaten :slight_smile:
with this App handles IR/IP commands in this fashion:

A separate command pipeline is created for each device in the list of commands and they run in parallel, so the delays in each pipeline do not delay the entire execution. So by the time the slow TV has finished powering on and its input is changed the receiver is ready and the bluray has started playback. But this is optional, you can make delays delay the entire process if you wish also.

And, more specific to my particular today’s curtain experiment - in order to emulate the physical momentary switch action I had to do Relay Open Delay 0, Relay Closed Delay 1, Relay Open Delay 2 for each flow. So you end up with 3 on-off-on actions for Open Curtains and 3 actions for Close Curtains.

Would it be possible to create a Mometary On action with the “ON duration settng” in milliseconds?

Or at least allow milliseconds as a setting in addition to seconds and minutes?

Thanks again, we’re breaking through to IR control!

Thanks for the report!

Re running the IR commands in sequence - I agree we should try to fix this, It would be nice if Homey itself could support this instead of building something specific in the app. How does it work for the other IR apps? Perhaps there are some upcoming changes re this in Homey 2.0? I’ll investigate a bit. However it would be fairly easy to implement command sequences in the app which could then be triggered from a flow. Also don’t forget that you could do a flow per device and then call the device “sub flows” from a main flow.

Re the relay Yes, I think a “momentary button”-function with a configurable press duration as you suggested would be the best fit. I’ll look into this.

Hi, thanks for looking into this and for the sub flow tip - I am still learning my way around Homey. As for the relay, by “configurable delay” you also mean “press duration”, right? In the physical switch world, that’s how long the switch contacts are engaged. before you release the button and they are disconnected again. We need this setting to work with various curtain controller manufacturers, if it’s a nanosecond they might not register it :slight_smile:

yes i meant press duration, edited.

Are the Global Cache Flex units supported also?
If not, has anyone tried to add one as a wf2ir itach device, and do they work as such?

Thanks

1 Like

It looks like they should be compatible from a quick look at the api specs so I’ve added the models to the ITach WF / SL drivers. Could you try by installing the latest master from github?

See: [HOW TO] CLI install method

Source: https://github.com/plarsson/com.globalcache

Thanks

I’ve added a duration setting to the relay command now. Please try it out by manually install latest from master:

https://github.com/plarsson/com.globalcache

Sorry couldn’t for the life of me figure out the CLI install method :frowning_face:

But I have since upgraded to v 2.0 and can’t iTach devices to Homey. Are you planning on updating it to work with v2? (sure hope so)

Thanks!

1 Like

Hi yes, I’ll update it to work with 2.0 soon. The plan is to make use of athom Web API so we can edit the config using the browser.

3 Likes

That is great news, sir! Ready to test!

Hi, can you please me help with string for command? I want sent command as in picture.

in iTest string *Z01ON is OK

I try any combinations:

        { "name": "on0", "value": "*Z01ON" },
        { "name": "on1", "value": "*Z01ON\u000D\u000A" },
        { "name": "on2", "value": "\u002A*Z01ON\u000D" },
        { "name": "on3", "value": "\u002A\u002AZ01ON\u000D" },
        { "name": "on4", "value": "\u002A\u002AZ01ON" },
        { "name": "on5", "value": "\u002A\u002A\u005A\u0030\u0031\u004F\u004E" },
        { "name": "on6", "value": "\u002A\u002A\u005A\u0030\u0031\u004F\u004E\u000D" },
        { "name": "on7", "value": "*Z01ON0D" },

Thx for your help

Hi all,

I’m trying to get my iTach Flex working through @pln’s Global Cache App. The published app doesn’t seem to support the iTach Flex but the code on the GitHub Repo is slightly more up-to-date. I’ve packaged it and installed it using the CLI and it finds my Flex (the published one doesn’t as the identifier isn’t supported).
The problem is I can’t figure out how to use it, I’ve added some Pronto codes in to the settings (changed in the source code before publishing as copy and paste isn’t working RN) but I can’t figure out how to send them. There’s nothing in the device when I click on it, and if I add it to a flow I get a page that asks me to select a relay command and then search for an iTach Connector (I don’t know what that is). I was expecting to see the device I added to the settings page in here.

I’m sure I’m being stupid, but can someone tell me exactly how please?

Thanks, Siobhan.

Hi all,
I tested the Bluestack (https://www.bluestacks.com/) to run the Homey-app in Windows! It works just fine to copy, paste Pronto codes!!

Hi all,

I am using an ITACH IP2CC. WIth version 1.1.0, I notices=d some changes using the “send relay command”.
What is the “number” field for?

Ow i see that the web app is not showing the correct info. On the Homey App it says “delay milliseconds”. Is this a correct parameter for the IP2CC? I can’t find any reference in the ITACH API? Also the ITACH IP2CC is not changing the relay with this version.

I tested with ITEST and that is still working.

Ignore my previous message if you saw it.

Looking at the code, the duration field looks like it allows you to invert the state of the device after a delay of x. So if you send a close and a duration of 1000. After 1 second it will re-open again. Sending nothing or zero should have no effect.

This change was made a while ago but not picked up until my changes for the UI and iTach Flex went live.

Unfortunately it is not working for my IP2CC. if II set the “duration in milliseconds” to “0” or “100000” msec. Can you please have a look at this.

Unfortunately I don’t have one of these devices to test with. I’m just working on what the code says it does instead of being able to test it.

IP2CC should work fine now with the latest version 1.1.2. Please try it out!