Homey Community Forum

Google Chromecast on Gllgle nest mini devices

Hi All,

I have a number of Google Chromecast devices. 3 of them attached to TV’s, working perfectly and showing up in Homey with no problem. They are ofcourse restarted regulary, as they get power from the TV.

I have recently acqiured some Google Nest mini also. The command part works perfectly with Homey. Both for normal turn/off lighting etc, however also for more advanced use including flows. It never fails, always do the relevant command (if google understands:-))

However, to have the google nest to say/play sound I have a problem. They end up as “Device not reachable” after some time, with the small red triangle. Normally after a few days, sometimes faster.

The strange thing is that they are fully working, they do still take commands, and are reachable in google app. However Homey will not send sound to them. If I restart the “Google Chromecast” app, they instantly get active again.

I have tried to look at the wireless network, moved the nest devices to the same 2G network as Homey to avoid any problems. However it does not make any differences.

And, the nest device are actibve on the network, working. Only Homey not able to see them.

Any good ideas? Or is this just a problem in the Homey Google Chromecast app, and I need to restart it?

Br
Sune

You have to add them as new chromecast devices.

OK, I will try. Delete them in Homey and re-add.

Have also moved them to static IP yesterday, even this should not make a difference, as they did not change IP.

Just a small update.

I deleted the devices from Homey and re-added them. They have been working perfectly since that, now more that 24 hours, all 3 of them.

Thanks for the idea.

1 Like

Hi All,
They started to disconnect again, from time to time, less frequently however from time to time. I think I know the reason.

When the Google Nest Mini goes into some kind of “wifi power save”, then Homey loos the connection, even the Google Home app is not missing it (it just uses more time connecting). I have looked for “disable wifi power safe”, however it is not in the setting.

Solution is simple, and have been stable for more than a week now. I have PC running for some server stuff, and I have implemented a simple ping session, making a ping to the nest mini every 5 second. This makes the mini rock solid in the Homey app.

If others have same issue, easy solution.

I also deleted my devices, after that i deleted the app.
Then i reinstalled the app, but when i try to readd my devices, i get the message “no new devices found”