Homey Community Forum

Google Services - App for Translate and new Text-to-Speech for any device with url input

If you have pressed save, and no voices are visible, then probably something went wrong with the billing acception.

2 Likes

I installed the app but i am not sure how to use it.
( i created account, activated the 3 api and created the json key and entered it into settings).
After setup i added a new device google tts device

How can i send a tekst to my google (mini) speaker?

When use a simple flow: Is flow started
Then (google tts device) begin te zeggen: dit is een test
This does nothing, i get a nice green v that the flow tan but i hear nothing.

Where do i choose which google speaker this should be broadcasted to?
I have several google cast devices in my homey, but not sure how i get this message to the correct speaker…

and how do i create this TTS devices?

I nowhere can select a device in my homey network which should be used to broadcast.

If i just add the second flow and i start it i get a red popup with an error that the json is not set but it is…

Devices → + → Google Services → Text-To-Speach → Connect → Next → Rename

For every end device / speaker you need 1 TTS device.

1 Like

ok, but how do i link ‘Google Services → Text-To_Speach’ to my device?

How does homey know which device is linked to my ‘google mini’ and which device is my ‘google TV’ etc
I have no option to link them and when adding them i also cannot choose/link them.
Also on the google API page is no linking to my device google device.

So i really do not understand how i can choose my end device…
Is the linkin in the renaming then?

I first used note++ but when i copied the jason no voice’s where shown.
Then i opend the jason with note (kladblok) and copied the jason. Voices where shown then.

1 Like

Have you install Google chromecast app on Homey?

yes i have google chromecast app from athom installed.
Currently there are 4 chromecast devices installed (i use that app for longer time)

This is done in the first flow:
image

The second flow is actually the Start/execute flow: (this flow calls the first flow automatically)

It’s multiple explained in this thread. So I can’t tell you nothing new.

You have a „Google Mini“. So please rename the added Google TTS device to „Google Mini TTS“, or whatever. The Name is only important for you to find the right device, nothing more.

Then create the main flow:
If…
— URL is triggered (please choose the device „Google Mini TTS“)
Then…
— Play an URL (please choose your „real“ Google Mini and choose the URL tag from the „Local tags“.
(Example: see the last post from @JPe4619)

If you want use TTS on your „real“ Google Mini then create a flow and you choose in the „And…“: Google Services → Google Mini TTS → Start TTS…

ok, but now i get an popup error:

The json which i downloaded during registration is filled in at the settings menu of this app…
But all other field are empty, the pulldown menu for default voice is also empty, no options to choose.

So i now did the following, created this flow:

and this flow:

When i start the secon flow i get the red errors from my last post…

I guess the error says that there should be something wrong with the JSON file.
It could possibly be that when the JSON file was copied, the text was changed from plain text to formatted text.
Or not the complete JSON file was copied.

But these are only guesses. Maybe Arie can say more about the errors.

Edit: As already mentioned in the first post of this thread, the easiest way to copy the JSON file is by using a browser. Open Developer → Tools → App Setting, choose Google Services and paste the JSON file.

(As mentioned before)

Here you can check if your JSON file is ok.

i did copy and saved it using developer website, not the phone app…

I already had an account for an other app, i had no errors during creating the api and billing…

The json itself is a valid json format

1 Like

Did you fill in the name of your Google Cloud Project without any mistakes in the app setting?
If so, then I’m out, sorry… :man_shrugging:t3:

yep…

I just removed the key at google, created a new one and tried again but same result…

I think i give up and remove this app, seems not to working for me…
Hope the TTS app will be fixed soon…

I received this email:
So this will stop working?