Homey Community Forum

Guide to Connecting gBridge to Homey for Google Assistant

Beste Peter, zou je kunnen vertellen welke instellingen je hebt gebruikt? Ik heb de hele post goed doorgelezen, maar krijg het helaas niet werkend.

Same as overhere:

Gents,

I managed to setup gBridge , MQTT Hub and MQTT Client where I set up a device in gBridge and successfully installed the device in my Google Home where I can see the device but clicking ON/OFF buttons is not working!

What I am doing wrong?

Thanks,

It’s important to know that a device showing in google home only confirms that the connection between gBridge and GH works. This is no indication that the connection between Homey and gBridge works.

The most common error by far that people do is that they have put the /set topic on the wrong place on gBridge config.

Check that the topic ending in /set is in the ACTION topic in gBridge and not the STATUS topic.

Thanks for the prompt response and can you please tell me how to test the connection between Homey and gBridge if is OK or not?

Thanks,

Either you can just try to go through the steps and double check that you’ve set it up correctly.

But there are ways to check it. For example by installing the application MQTT Explorer on your computer and connecting it to the gBridge broker. There are explanations in this thread on how to do it.

In that application you can pretty easily see where the problem is, if it’s in the settings in Homey, and sometimes what setting or if the problem is the setting in gBridge.

Here we go MQTT Explorer’s screenshot:

And my device at gbridge:

Whats wrong here any help please?

Thanks,

Set belongs on the other side and you are not allowed to use capitals. So:
action: …/livingroom2/onoff/set status: …/livingroom/onoff

Thanks, So I need to keep the whole lines like this?

Action : gBridge/u674/d4064/livingroom2/onoff/set
Status : gBridge/u674/d4064/livingroom2/onoff

Thanks,

You also need to delete the “d4064” part of the topic. It’s some default naming thing from gBridge that does not belong.

Check the first post (the guide) and look at what the topics contain there.
gBridge/Username (u674)/name of device/capability/(set, if action)

Edit:
Also if you have the setting “Normalize” set to OFF in MQTT Hub you are allowed (and must) use capitals. If you set it to ON then spaces turns into dashes (-) and capitals turns lower case. But both should work as long as you type it in exactly as they look in MQTT Explorer (IMPORTANT!!). I prefer normalize on but it’s not a necessity.

1 Like

And… it stopped working again here. Restarting client/hub didn’t solve it.
God, I hope Google approves Homey soon… :frowning:

@Fire69 There’s a bug in Homey Core.
As far as I know: Athom (WeeJeWel) already dealt with it and the next Homey release will (probably) contain the fix.

This is all catched by @Jamie and a temporal solution can be found here:

Had the same three days ago. A restart of homey and client and hub did it also

@Fire69 Can you confirm if this solves your issue?
If there are any issues with the Hub, please let me know.

Followed Jamie’s instructions and it’s working again now.

Let’s hope the fix will be available soon.

Guys
Peter has plans to improve and develop the service. I just saw this on Kickstarter - https://www.kickstarter.com/projects/1720541463/gbridgeio-control-anything-with-voice-commands

I will back it just to help support and develop this further

2 Likes

works like a charm even in dutch :slight_smile: I back this gBridge.io on KS…!

@Deojuvente Great, at least you back one side of the medal!

1 Like

11 hours left to back this project!