Homey Community Forum

HeatIt App

Hello everyone,

This is the new topic for the HeatIt Z-Wave app, the app is made to support Heatit products as they release.
Here we will answer questions and post changelogs as we update the app.
Don’t hesitate to contact us at post@heatit.com or write us a message here!

4 Likes

Welcome to the forum and thanks for picking up support! Is there a way to include the Heatit z-push button 4 unsecure, and/or have them send association commands unsecure? Right now I can no longer use associations because fibaro dimmers do not support S2 security and the buttons do, so they do not respond to the associations.

This is really important to me because a) dimming works way better and b) the lights still work when Homey isn’t functioning properly.

Hi Edwin,
Currently it is not possible to choose the security level you choose to include in on Homey.
The secure level is chosen within the code and currently we are planning on following Ted’s code.

Apologies for any inconvenience this may cause.

Welcome! Great to see support from the manufacturer. I second the request from Edwin. Would be awesome. So maybe a suggestion for the roadmap.

Hi @HeatitControlsAB !

Welcome and thank you for continuing the great work TedTolboom has done !

I have 6 Z-TRM3 installed in my home, and they work great.

I was however wondering if you could add a cooling mode to the thermostat. I’ll try to explain my situation : In my house I have a heat pump to produce hot water which is used for the floor heating during winter. In summer however, cold water is injected in the floor, instead of hot water, which helps to cool the house a bit (hardly any house is equipped with A/C in Switzerland). I was therefore wondering if you could add a cooling mode, in which the Heat It Thermostat understands that when I ask for a lower temperature, It should open the valves of the floor heating (cooling in this case) and not close them ?

I hope I’ve been clear enough in my explanation but as English is not my mother tongue, I sometimes fail in translating my ideas from french to English.

Thanks in advance & have a nice day.

Q.

You could solve this with flows. You only need a dry contact for the heat pump, which tells you if it’s cooling or not. Of it’s cooling you have seperate flows that become active.

My problem is not really about creating an automation based on the mode the heat pump is in, it is more of a convenience problem. Right now I have to set the Thermostats to 30•C during summer, to ensure that the floor heating valves are opened and injecting cold water in the pipes, because they don’t have any “cooling” mode, only a heating mode. As the temperature never gets (hopefully) to 30•C inside the house, the Thermostats are tricked into believing I want them to open the valves to get to that inside temperature (which is in fact cooling the house)… The problem is that I cannot regulate how much the valves are opened because the thermostats are always telling them to be fully opened to get to 30•C.

Hope I was clear enough. Thanks for trying to help anyway :slight_smile:

1 Like

I get it. :blush:

But I had the same issue and don’t have to trick the thermostats in this way. They can be set at your ideal temperature and since Homey knows if the pump is cooling or not the ‘smart’ stuff happens there, not in the thermostat. But yeah, if you want the thermostat to be the smart part you need a cooling function.

Oh my bad, didn’t know you could do that !

To be honest I wouldn’t even know how to program it, as the heat pump doesn’t communicate with the homey directly. Moreover the thermostat are the one ordering the valves to open or not, I’m not sure that the heat pump is involved in that decision.

That’s one way to do it. Direct communication between valve and thermostat. I also use the Z-Water and thermostats but to know when the heat pump is cooling, I chose to go via Homey. Anyway, if you ever need more information, just let me know!

Hi,

I have just installed 7 pices of Z-TRM3 thermostats from HeatIt a couple of weeks ago, using the HeatIt app in Homey. There was some small issues, but it was not that hard to get them all up and running. Just had to reinstall a couple of them before they were working as they should. They worked fine for some time, but about a week ago, at the same time as Homey released the new software version 7.1.1, some of the thermostats stopped reporting values to Homey. It might just be a coincidence.

I have tested changing group 1 from 1.1 to 1 and back to 1.1 as mentioned in another post in the forum, but this did not help. I can also see that I am no longer able to go in to advanced settings to do changes on the termostats as they repond with a fault message that it is not possible. I then desided to try to remove one of the thermostats and connect it again, but there is no way that I can get the thermostat to communicate with Homey. I have done this with all the thermostats a couple of weeks back and did not have this type of problem. I have also restarted Homey several times and I have power off the termostats and back on again.

At the moment it looks like 3 thermostats work fine, 3 are not reporting values and 1 that I have tried to reinstall are not possible to connect any more. Also note that there are the thermostats closest to Homey that has the problem and the one I am tying to reinstall are only located 2 meters from Homey.

I find it a bit suspicious that this happened at the same time as software version 7.1.1 of Homey was released, as this also statets the following in its release note: " [Z-Wave] Update send command options for improved stability".

Have anyone else experienced something like this? Any suggestions to what can be done?

Hi,

I have problems with losing connectivity to my Z-TRM3. It is located in the same room as Homey.

Nodes in the route (2 and 128) does not exist in my network.

Any ideas?

Hello, I have the exact same problem. Also have 7 of them. Occasionally one or more of my z-trm3 thermostats stops responding.
Have you tried switching the circuit breaker off and on? That always helps for me, it instantaneously comes back online again. Also resetting them and including them again fixes it also.

I actually had one go offline, then fixed it with the circuit breaker. Went on a 12 days vacation, and when I was away i checked every day. No problems untill i came back home again. Day two of getting home one went offline again. Almost seemed like when the zwave network starts getting traffic the thermostats get in trouble.

I had only 3 thermostats before, included unsecure and never had any problems. Then now in July i bought 4 more and excluded my old thermostats, included them back with S2 secure and also the new ones. So don’t know if it was after 7.1.1, seems to me it started happen after i included it with S2 secure.

I’ve contacted heatit about it, but haven’t gotten any answers yet…

I’ve also seen the problem been mentioned on other forums, like here:
https://forum.z-wave.me/viewtopic.php?t=34277

Do @HeatitControlsAB have any ideas of what is going on here?

I can now see that all of my 7 HeatIt Z-TRM3 has stopped communicating. I used Homey Insight to se the log for temperature values. All of the 7 has stopped reporting values trough the last week. Not at the same time, but it looks like one and one is dropping out and there is not possible to get them back online again. I have switched the circut breakers off and on, restartet Homey and tried to reinstall Z-TRM3. Nothing is working anymore. I have other components communicating on Z-Wave (relays and socket outleets) and this are still responding as normal.

I find it a bit strange that all 7 starts to have issues allmost at the same time.

I am trying to add a Heatit z-push button 8 to my homey pro, but I always get the error message «no compatible homey app found for this unit. A basic z-wave unit has been added to the system», even though the heatit zwave app is installed on homey.

Du anyone have a suggestion what I can try here?

1 Like

Same here, worked fine for months unsecure, but problematic now on 7.1.1 with S2 secure.

We are currently looking into the issue that has come up with the new version of Homey and we will let you know once we’ve been able to resolve this issue.

5 Likes

I have now been able to get all of my 7 thermostats online again. The solution was to do a full fabric reset of the physical thermostats. Then to do a new installation in Homey. They have been working stable after this. To me it looks like this Homey update 7.1.1 made something hang in the thermostat itself.

I also did a factory reset earlier, still lost contact. I did another factory reset today, this time I entered the code 00000 instead of the one on the sticker so it is now included as unsecure.