Homey Community Forum

Heatit Z-wave app (v2.4.2)

I had similar problems with my Heatits. All 7 was loosing connection over a week.
For me this worked:

My 7 Heatit TRM2fx all lost connection with the Homey within 36h.

The solution was to change the parameters:

Temperature report interval (s) from default 60 to 3600
Meter report interval(s) from 60 to 32000

My conclusion is that the frequent communication of the Heatits overloaded the z wave net sometimes.

1 Like

Hi all,

I have a test setup with 3 thermostats and some fibaro wall plugs sensors etc.

Also losing contact while the nodes are connected to Homey when hitting test. There is no data coming in and commands do not work.

This happens to random thermostats after a few hours so it does not seem distance related. Temp reporting is also hit and miss after pairing and resetting.

Setting on interval are changed as suggested but this does not help on all. They also seem to disturb the otherwise healthy network.

All apps and firmware up to date. Any other tips?


When you loose connection, prior of this, do you in a flow adjust all thermostats at the same time? I have experienced that setting a delay in the flows helps. My hypothesis is that the Heatits are overloading the network, and that a delay helps spreading the “load”. But I am a pure noobe with homey and Z wave…

Best regards Arnfinn

Thanks for the reply!

I am trying out a schedule with the scheduler app but on 3 thermostats (Heatit TRM2fx) it hardly seems like a heavy load?

I can reset and add the 3 thermostats without pushing any flows. They do seem to interfere with the network. Any experience with different controllers?

I applied these settings a soon resetted it the last time. Didn’t seem to help. :frowning:


Looks like my settings. Did you check out the Developer page and try to “Test” or “Heal” the nodes?
Does the Heatits work for some time after inclution?


Hi guys,

Recently bought the Heatit Z-TRM2fx and a electrician installed it for me. I was wondering if anyone has had any similar experience when pairing it with homey? I have the beta version of the app installed.

When I try pairing it with Homey the Thermostat displays “Inc” which means it has been included. However, at the same time in the homey app the message is stuck at Please wait while your device is being added… and after waiting a minute or two i get the message No Z-Wave device was found

I’ve tried

  1. When I try adding the device to the homey again (since it does not appear in the app) I get the error message that the device is already included.
  2. I’ve excluded the device and tried including it again.
  3. Resetting the Thermostat to factory settings and adding it again, same issue.
  4. Reinstalling the application.
1 Like

Yep, it works for about 3-4 days after inclusion. Will have to try the heal thing thou.

Which firmware are you running on your trm2fx?
(I’m using 3.4)

Using Heatit app in Homey it doesnt respond via Homeykit link normally. Hard to understand if this is issue of Homeykit app, Homey itself or Heatit app. But other devices seems to respond better.

I am probably stuck with the same problem… @Vidar_Andersen Have you resolved this problem? @TedTolboom Is this anything you can fix in the app?

I was hoping @TedTolboom would fix it, but i delivered the device back and got my money while waiting for a solution.

Solved by using the ROBB smarrt app instead!

1 Like

@Vidar_Andersen @kentok lately I have been pretty occupied with other (private) stuf, not allowing much time to work on the app.

Yes, I am able to fix it and also received a request from Heatit to do so…
but it might run into issues when multiple apps are using the same ID’s.

I’ll need to check how to properly implement this.


As you saw in my previous post, your ROBB smarrt app is working with the Heatit Z-push Button 8 with Sunricher code.

@TedTolboom Any plans to add support for the Heatit Scene Controller? https://www.heatit.com/z-wave/heatit-z-scene-controller/ The advantage with this one is that it is wired and also works as a repeater.

I know :stuck_out_tongue_winking_eye:

Yes, luckily enough, it will be porting a device driver from another app to the Heatit app :face_with_raised_eyebrow:
The implementation of this device is a real pain in the … :rofl:

1 Like

I’ve just uploaded v2.2.1 to the Homey app store, awaiting Athom’s approval:

@Arnfinn_Gilberg I’ve updated the default temperature and meter reporting interval from 60 to 900 seconds to prevent the Z-wave lock-up as you mentioned. 900 seconds should be sufficient.

Note: this will only change the interval for newly included devices (basically overruling the device settings). Users that have already included the Z-TRM2(fx) and that are experiencing Z-wave slowdowns, need to update the settings themselves; no need to remove or re-include

@Vidar_Andersen with this update also the issue is resolved for not being able to include some of the Z-push button devices.


Thanks for this app! Is there a plan to support Heatit Z-Dim in the future? I had an electrician offer to install those in my house so it shouldn’t be far away from the market.

Talking about this

I’m already testing them, ssssst :stuck_out_tongue_winking_eye:

Good news :smiley: