Homey Community Forum

Heatit Z-wave app (v2.4.2)

Using Heatit app in Homey it doesnt respond via Homeykit link normally. Hard to understand if this is issue of Homeykit app, Homey itself or Heatit app. But other devices seems to respond better.

I am probably stuck with the same problem… @Vidar_Andersen Have you resolved this problem? @TedTolboom Is this anything you can fix in the app?

I was hoping @TedTolboom would fix it, but i delivered the device back and got my money while waiting for a solution.

Solved by using the ROBB smarrt app instead!

1 Like

@Vidar_Andersen @kentok lately I have been pretty occupied with other (private) stuf, not allowing much time to work on the app.

Yes, I am able to fix it and also received a request from Heatit to do so…
but it might run into issues when multiple apps are using the same ID’s.

I’ll need to check how to properly implement this.


As you saw in my previous post, your ROBB smarrt app is working with the Heatit Z-push Button 8 with Sunricher code.

@TedTolboom Any plans to add support for the Heatit Scene Controller? https://www.heatit.com/z-wave/heatit-z-scene-controller/ The advantage with this one is that it is wired and also works as a repeater.

I know :stuck_out_tongue_winking_eye:

Yes, luckily enough, it will be porting a device driver from another app to the Heatit app :face_with_raised_eyebrow:
The implementation of this device is a real pain in the … :rofl:

1 Like

I’ve just uploaded v2.2.1 to the Homey app store, awaiting Athom’s approval:

@Arnfinn_Gilberg I’ve updated the default temperature and meter reporting interval from 60 to 900 seconds to prevent the Z-wave lock-up as you mentioned. 900 seconds should be sufficient.

Note: this will only change the interval for newly included devices (basically overruling the device settings). Users that have already included the Z-TRM2(fx) and that are experiencing Z-wave slowdowns, need to update the settings themselves; no need to remove or re-include

@Vidar_Andersen with this update also the issue is resolved for not being able to include some of the Z-push button devices.


Thanks for this app! Is there a plan to support Heatit Z-Dim in the future? I had an electrician offer to install those in my house so it shouldn’t be far away from the market.

Talking about this

I’m already testing them, ssssst :stuck_out_tongue_winking_eye:

Good news :smiley:

Just re-bought the heatit Z-push button 8 with the Sunricher branded device, and it now works like a charm! thanks @TedTolboom

1 Like

I bought Heatit Z-TRM2fx several months ago and initially got it associated with Homey. However, it was not reporting the current temperature and after I noticed there has been updates to the app, I decided to try re-association.

After excluding the device I tried to associate it again, but now the device is not found. Homey shows the message No Z-Wave device was found.

This seems similar to what @Kadru is experiencing. Any ideas how to get the thermostat associated again?


What works for me is removing any unknown nodes from the developers page and resetting the thermostat each time after a failed attempt. Also keep the Homey real close to the unit…

Best of luck!

and the device is removed correctly from homey, try Settings —>Zwave—> Remove Zwave

Thanks for the hints @Balster_van_Duijn @RoyWissenburg. I did have some unknown nodes in the system but they are now removed. I re-tried association last night and this morning but both ended with error being displayed on the thermostat screen.

I have Homey located 40 centimeters from the thermostat.

How do you reset the thermostat between attempts? I tried just turning the fuse off for a short while.

Is it possible to somehow see logs from the association process in Homey? I tried enabling Z-Wave logs in the developers site, but the rows I saw seemed to be related only to existing nodes. Didnt see things that would look like being related to new nodes.


I’ve reset it through this method:

“By pressing buttons Right and Center (down and confirm) for 20 seconds, the thermostat will perform a complete factory reset. NB! Please use this procedure only when the primary controller/gateway is missing or otherwise inoperable.”
Link: http://manuals-backend.z-wave.info/make.php?lang=en&sku=HEAE5430555&cert=

I still haven’t solved my issue with pairing. Figured I’ll wait a few weeks and give it another try.

Always reset, keep the homey right up to the unit!

Association worked after resetting the thermostat like @Kadru described above!

However, I still did not see the current temperature being reported to Homey as expected with the fixed version. Is there any way I can troubleshoot that?

I also noticed that I’ve now lost contact to the thermostat again (after turning the mode to off with Homey) so I think I will need to redo the association when I get home…