Homey Community Forum

Heatit Z-wave app (v2.4.2)

i know, it still does not work 100% I also have a couple of units the do not report current temp. Also some units loose connection after a few days.

It seems that the 900 reporting fix is not a 100% fix.

I was not able to connect to the thermostat anymore after setting it to off with Homey. But I got connectivity back after a long pressing a button on the thermostat.

Now I’m getting temperature reported too. Very good. Thanks for the help!

Toni

Please assist :slight_smile: I have a qubino flush dimmer included. Works with the homey app. I´m having problems making the direct association with the z-push 2 button. Do both have to be secure/non secure? Is there a trick ? It simply will not work (crying :slight_smile: )

I recently installed 3 new Z-TRM2(fx) units which all have lost connection within a week. Reporting interval is at 900 so it doesn’t seem to be a fix for me unfortunately. Anyone had more luck trying different things?

It works like a charm after resetting z-wave network and resetting thermostats and then adding them. But then one by one they are falling out of the network.

I have tried everything in this post, but it’s always the same result. After few days they are not working.

My setup is 3x Z-TRM2(fx) units within a small apartment of 35m2.

Would be nice to have the possibility to reset power meter…

Hard to implement?

I can’t find the code to turn on the Heatit Z-wave thermostat controller in homekit. can you tell me where to find him?

Hello, just tried to integrate the newest heatit thermostat but this is not working. I’m talking about the Ztrm2fx latest version. Was aviable this year.

I mange to integrate z wave thermostat but not the Ztrm2fx

Is the Heatit Ztrm2fx working with the firmware update 3.6 or should I use the already installed firmware on the thermostat before including it to Homey?

I don’t know since I did not make the heat it app maybe some other users tried this out? I never updated my heatit thermostat.

I have the exactly same issue :frowning:

@TedTolboom Latest update:
I managed to integrate the new heatit ZTRM2FX but u need to hold homey right under it. Don’t know why but I hope the developer can fix it? The z wave thermostat I got it’s to rooms away and integration were no problem.

In the first weeks I got running my thermostats without any issue but now I lost completely control to them by my flows they don’t react. It’s obviously this app is not working for the heatit Ztrm2fx. I hope the app creator can fix this soon as possible ? I will send a request to homey if they could make a app… for me it’s necessary to get my heating working or I need to change the hub. Or sell all heatit thermostat and buy something wich is actually working to homey…

I beg the app creator to fix this if it’s running of course i like to donate.

Best regards.

1 Like

@Alex.Robins, @Torill_Iversen, @Kadru, @Tukun, @Andren, @Mapap, @Balster_van_Duijn, @Toni, this weekend I finally had some spare time to dig into the Heatit Z-TRM2fx issues (with or without FW 3.6) as reported.

What I noticed is that once added, the thermostat and Homey are almost constantly communicating, which can not be related to normal data transfer. Based on the Z-niffer data, it appears to be Z-wave S2 security handshakes not being completed to each of the devices desire (implementation). Please note that security handling is completely (!) outside my reach or influence as Heatit app / driver developer.

Specifically in Z-wave networks with multiple Z-TRM2fx devices, this might lead to clogging the Z-wave network / Z-wave communication chip. Which also explains why I can’t reproduce the same issues with only one development Z-TRM2fx.

I’ve shared my data and insights with both Athom and Heatit and am awaiting their feedback.

Until these S2 security issues are being resolved (IMHO not expected on short term), a containment might be to force the non-secure inclusion of the Z-TRM2fx (also applicable to the Z-Water and Z-Relay).

To resolve these issues, users will then need to remove and re-include their thermostats to Homey (non-secure). Which is a step (‘forcing’ users to re-add their devices and moving to non-secure) I strongly dislike as developer!

I am testing this updated version of the Heatit app at my test setup; which is looking very positive.
Based on the feedback of Heatit and Athom, I expect to be able to release this updated app as BETA to the app store early next week. Keep you updated.

1 Like

Hello @TedTolboom, Thanks for your reply and looking inside that issue.

For understand the issue right is the problem the communication between heat it ZTRM2FX and Homey. As I know this thermostat works fine with Fibaro Home center 2 the problem must be then Homey. Am I Right? So this device are clogging the network that user can experience a slow network for all other devices?

Could this issue also prevent the heat it ZTRM2FX from pairing with homey? I just installed the ZTRM2FX. When I try to connect it to homey it gives constant errors. As stated above I moved homey close to the ZTRM2FX. The I got a message on the thermostat “inc” but homey said “ no zwave device found”. The thermostat didn’t install correct. After that I couldn’t remove it through settings -> remove a zwave device. I also couldn’t add the device to homey as I constantly get a message: no zwave device found.

@Rdw ultimately yes.

Recommended instructions to include the Z-TRM2fx:

  1. Manual reset of the thermostat by holding the right two buttons for more then 20 seconds
  2. Move Homey as close as possible to the thermostat
  3. Wait until Homey is fully initialized; typically 30 minutes after re-applying the power
  4. Include the thermostat to Homey

I will released the updated app to BETA end of this week.

I’ve just released v2.3.0 of the Heatit app to the app store; awaiting Athoms approval.

This update has shown to resolve the stability problems that exist with the S2 security based devices (Z-TRM2fx, Z-Water and Z-Relay), by forcing non-secure inclusion (available as of Homey 2.4.0).

Users experiencing issues with these devices, are advised to update to the BETA version of the app and re-include these devices (manually reset the device after removal from Homey and before including it again).

1 Like

Thnx @TedTolboom for your response and efforts!

Version 2.3.0 (BETA) is available in the app store.

Advised approach for the users that want to re-include the Z-TRM2fx based on this update.

  • Install v2.3.0 BETA version of the app
  • Move Homey to close proximity of the thermostat (Homey does not support inclusion of the network) and wait sufficient time before Homey finished starting up all apps (~ 30 minutes.
    • If multiple thermostats need to be re-included, connect Homey to a powerfull enough powerbank and move it around.
  • Remove the thermostat from Homey, by going to ‘device settings’ > ‘Remove device’ and follow the instructions (mind updated step 5):
    1. Press the Center (confirm) button for 10 seconds. The display will show OFF.
    2. Press Right(down) button 5 times till you see Con in the display.
    3. Now start to remove the device from Homey.
    4. Start exclusion mode by pressing Center(confirm) button for approximately 2 seconds. The inclusion / exclusion icon will appear in the display.
    5. Confirmation will show EcL in the display.
      When Err(error) appears, check if the thermostat has been removed from Homey. If so, reset the thermostat according to the instructions of the manual. Otherwise repeat the exclusion.
  • After removal from Homey, manually reset the thermostat by pressing the right 2 buttons of the thermostat for 20 second, during the last few seconds res will be shown in the display.
  • Set Homey in inclusion mode by only using the following method Add device > Heatit > Z-TRM2fx, the specific Z-TRM2fx inclusion instructions should be shown
    • Don’t use the generic option Add device > Homey > Z-wave, since it will not overrule the default secure inclusion!
  • Re-include the thermostat to Homey by following the inclusion instructions (mind the addition in step 5):
    1. press the Center (confirm) button for 10 seconds. The display will show OFF.
    2. Press Right(down) button 5 times till you see Con in the display.
    3. Now start add a device to Homey.
    4. Start inclusion mode by pressing Center(confirm) button for approximately 2 seconds. The inclusion / exclusion icon will appear in the display.
    5. Confirmation will show Inc in the display.
      If Err(error) is shown on the thermostat display, inclusion might still be successfull; check the functioning of the newly added device.
2 Likes

So far so good! Hopefully this will fix the problems basically everyone has been experiencing.

4 x Z-TRM2fx

1 Like