Homey Community Forum

Heatit Z-wave app (v2.6.1)

Thanks @TedTolboom for the Beta and the work you have done now with fixing the issues. I have put all of my 10 heatit termostats over and now they are (finally) working as they were supposed to
:blush:
I will donate for your work :+1:

Thank you @Torill_Iversen for you feedback and contribution. Much appreciated!

Thanks for the new update. I have been testing it for 2 weeks now without any dropout of the thermostats. I only had some issues adding it to the homey, but after some resets and remove any node on homey, I could add it.

1 Like

Hi,

I have a new homey (late 2019) and the latest app versjon. I amtrying to pair my z-trm2fx but all i get is «err» on the thermostat and the pairing times out on the homey.

  • I have tried moving the homey closer (0-100cm)
  • i have tried to factory reset the thermostats

Any ideas? Is it just to keep on trying…?!?

Did u try this?

1 Like

Hi,

I had not tried this (had not found it in the forum), but it worked. Here is what worked for me:

  • followed step 1 and 1a here: Adding a Z-wave device to Homey [Howto]
  • factory resetted all thermostats
  • some would include right away. Some would not
  • those who would not include: factory reset thermostat and try again. Repeat untill it was found and included

Ps: held the Homey into the thermostat.

Thank you for your help!

Cheers. That’s what a community is for aye!

1 Like

Hello. Does anybody knows if it is possible to connect digital DS18B20 temperature sensor to Heatit thermostat? There is no official connector, but may be there is some pins on the board?

I have a fem Heatit z-push Button 4. It looks like it is not supported at the moment. Are you planning to support this as well?

2 Likes

Hello Community,

Is it possible to set the actual temperature to an external sensor or a variable instead of the internal/connected sensor. I would like to sent the average temperature of different sensors of one floor to the thermostat.

Regards
Andreas

2 Likes

Hi, and thanks for a great app.

My apologies if this has been covered already, but I have a question about the ‘Energy’ functionality. I’m running app version 2.4.0 and I see there is a “Constant power usage” parameter in settings, I assume this is for setting the size of the heating element (in my case underfloor heating). But in Homey Energy tab this power is reported continuously regardless of heating state. I.e. it appears as if full power is consumed also when the thermostat is not engaged.

Am I doing something wrong or is the correct version yet to be deployed?

Cheers
Frode

I have the same request…

@Jan_Iversen yes, I am awaiting to receive the 4-button version myself, so I can add support for them in the next update.

Assuming you are referring to the Thermostat. I don’t think the device allows for receiving external Z-wave temperature reports… So I would say no.

Good one. Homey energy is looking to the onoffcapability, whereas I needed to use a custom capability thermofloor.onoff. So Homey energy is not noticing a switch.
Based on this feedback, I do anticipate that your are using the ‘old’ Z-wave thermostat?

Yes, I believe it’s the old one. I’ve had it for over a year. Is there any hope of fixing this issue or will only newer version report correctly? I tried “cheating” by copying the state to a virtual device, but it seems that app also needs updating (not an issue for this thread though).

1 Like

Hi, i have heatit Zwater and i use temperature sensors connected to it to control under floor heating. For setpoint i want to use vthermo app which is great. The drawback here id that i dont find a way how to show 4 temp sensor in 4 separate rooms. Someone can give a hint?

Thanks for a great app! :grinning:
Will the z-push button 4 be supported any time soon?

1 Like

I have a heat-it zwave plus termostaat installed in my bathroom with a floor sensor. But the temperture of the floor sensor doesnt update in the homey app. So it keeps saying 17.8 degrees. What do i wrong?

@Jan_Iversen @thomahawk @Benjamin_Hohner With a contribution of @henrikln (greatly appreciated), support for the Z-Push Button 4 device has been added to the Heatit app (v2.4.2).

App is submitted for app store approval by Athom.

5 Likes

I am still having problems with meter readings.

Even after all updates and repairing.

I only get new readings after rebooting homey.
So reading it back does work, havei missed a setting?

Now i get this graph? (every change is a reboot)

Works great, @TedTolboom. Thx.